0

This is a question that was asked on apple support community but did not find any answer. I am having exactly the same problem, I hope someone here can help.

In Mail -> Preferences -> Junk Mail, I have deselected "Enable junk mail filtering" ... yet the "Junk" mailbox still appears in the left column, and various emails are still being directed to "Junk." (from apple support forum)

I don't care whether or not the "Junk" mailbox is visible; I just don't want Mail to direct any emails into the "Junk" folder. And, as I noted in my original inquiry, I already DID deselect "Enable Junk mail filtering."

So, to reiterate my original question: "How do I make emails stop getting directed into the Junk mailbox?" This was never a problem prior to Mavericks.

As in the question of the op on apple support, this seems to start happening since the Maverick update and occurs only with my gmail/IMAP account.

Any idea on how to effectively disable the Junk box of Mail and not have these emails deleted from the gmail server?

2

One at the time. Your web mail (the Google web site)

Use settings there to show or not the Spam folder in Google mail. Google (gmail) said: messages that have been in Spam more than 30 days will be automatically deleted!!

Now you can show or not on your Computer (by selecting or not the SHOW in IMAP)

On your computer: After you have disabled the show in IMAP in gmail settings, restart your computer's email (Mail.app) program, and the Spam/Junk Folder will be gone.

The next is in Disable the Junk mail filtering on your computer that is done here.

enter image description here

Remember the Gmail (web) will be still filtering according to your junk mail settings there.

  • 1
    Thanks for your answer. It answered my former question, but my question was unclear, sorry about that. I edited it to make it more precise, the significant addition being : "I don't care whether or not the "Junk" mailbox is visible; I just don't want Mail to direct any emails into the "Junk" folder. And, as I noted in my original inquiry, I already DID deselect "Enable Junk mail filtering." So, to reiterate my original question: "How do I make emails stop getting directed into the Junk mailbox?" This was never a problem prior to Mavericks." – Martin Van der Linden Feb 13 '14 at 16:44
  • 1
    Let's clarify, when you right click on any email in Inbox do you have a Mark as junk option or is it grayed out. – Ruskes Feb 13 '14 at 16:53
  • It is grayed. Also following your advice to make the spam box visible on the gmail website, I recovered the email I thought disappeared from gmail servers ( I edited the question accordingly). Somehow another spam box (marked in my native language "courrier indésirable" !?!) was visible before which tricked me into believing that there was no other place to look for spams. I guess I should conclude that the problem comes from gmail and not from Mail... – Martin Van der Linden Feb 13 '14 at 17:01
  • 1
    Grayed out confirms you do not have the Junk mail filtering going on in Mail. The Junk folder you see in your Mail are from Gmail if Show in IMAP is enabled. – Ruskes Feb 13 '14 at 17:11
  • 1
    Great, it worked and we learned something :) – Ruskes Feb 14 '14 at 19:14
2

I had the same problem and I discovered that under Preferences>Accounts>Mailbox Behaviors you can disable the "store junk messages on server" setting for each account and that seems to hide the junk mail that was apparently not visible in previous versions of Mail.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .