0

Lately some of the emails I get from a particular website have started going into my Junk folder. I have the sender address in my Contacts, and in Mail's Junk Mail preferences I have the box "Sender of message is in my Contacts" checked. Yet this doesn't seem to be working, they're still being filtered. The site is an online forum, and it emails new postings in threads I've subscribed to.

I also had the option "Perform custom actions" selected. I think this may have been left over from years ago when I was also using a third-party spam filtering plugin. When I look in the "Advanced..." page, the conditions are equivalent to all the checkboxes on the main screen. I tried changing that option to "Move it to the Junk mailbox", but this actually made things worse -- instead of just a couple of the messages being moved to Junk, almost all of them were -- so I put it back.

I haven't figured out what might be distinguishing the messages that are being marked as junk.

Any idea why that option isn't really exempting them from junk filtering?

EDIT:

In case it's relevant, I also have a rule that matches these messages; it matched the sender and subject line. It was just marking them as read (I have a menulet that shows the number of unread messages, and I don't want these included). When the messages were put in Junk, they were still marked as unread, so this must be happening before rule processing. I tried changing the filter to move them to a new folder, it didn't help.

  • Could you please include in your OQ a screen capture of Mail > Preferences... > Junk Mail and Mail > Preferences... > Junk Mail > Advanced? – dan Jan 12 at 18:41
  • Did you check the real sender of one of these messages marked as Junk? – dan Jan 12 at 18:43
  • Yes, I did. It matches the address in Contacts. – Barmar Jan 12 at 19:01
1

This turned out to be spam filtering by the ISP (Comcast), not Mail.app. Since they use IMAP, the ISP's Junk folder is sync'ed with the Mac's Junk folder, so when the ISP filters it it looks just like the client filtering it.

I went to the ISP's mail settings and disabled their spam filter, and the problem went away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .