After upgrading to Mountain Lion, I get the following error message when I launch Calendar.app:

"Calendar Cache couldn't be moved because you don't have permission to access "Calendars".

Screenshot of Calendar app with error dialog

When I click "OK", Calendar quits.

This user is an administrator on the machine. I tried granting the user 'Read & Write' access to Calendar.app, but nothing changed.

I have another administrator account on the same machine that can launch Calendar.app without issue.

2 Answers 2


If repairing permissions with Disk Utility and/or checking permissions for the actual calendar-files in /Users/<username>/Library/Calendars do not work maybe this will:


Seems a bit drastic though. I have not tried this myself. I suggest having a backup just in case.

Update: I just tried the instructions from the thread at apple discussions, and everything on my 10.8 system is OK. It's kind of a supercharged permissions-repair (lacking better terms atm).

If it works, thank macjack at the appe forums. If not, tell me :)

On my mac the ~/Library/Calendars/Calendar Cache is owned by me:
-rw-r--r--@ 1 nils staff 2813952 Jul 31 18:44 Calendar Cache

It may be of help if you post the output from this terminal command:
ls -lar ~/Library/Calendars/|grep "Calendar Cache"

  • The permissions on Calendar Cache are identical to what you posted. Commented Aug 2, 2012 at 3:51

Since I've never actually used iCal/Calendar.app on that user account before and there was no data to potentially lose, I decided to try deleting ~/Library/Calendars/Calendar Cache entirely. Calendar.app started without complaint after that.

I'm not sure what would have happened to my calendars if I actually had anything in Calendar.app to lose, but it did fix the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .