11

After updating to El Capitan, my friend found her Calendar.app runs extremely slowly. Clicking the button to move to the next week's display results in spinning beach ball (the new one). Beach ball spins for something like half a minute. Makes the app practically unusable for someone booking appointments while the customer waits.

The same calendars shared over iCloud run nearly instantaneously on an iPad Calendar app (iOS 9.0.2). So the problem seems to be Mac-only.

All other apps run well. Only Calendar is beach-ball-spinning slow.

Calendar.app was already annoyingly slow in Mountain Lion & Yosemite, but is much worse in El Capitan. This computer has been upgraded through the years across these OSes.

Perhaps crud has accumulated in the Mac's local files for these calendars. Is there some way to rebuild or replace the Mac's cache of these calendars and get fresh copies from iCloud?

Any other workarounds or solutions?

6

I guess I had the same problem and just found a solution - at least in my case it helped a lot. Not as fast as it was in the past but much faster than it was after updating to El Capitan. And no more spinning balls ;)

Close Calendar.app, go to ~/Library/Preferences/ in your home folder and delete com.apple.iCal.plist.

Good luck!

  • Careful to go to the right Library/Preferences folder! You As Stefan said you want to go into the one that's in your user folder, not the main system one. – Harv Oct 20 '15 at 21:11
  • 1
    Definitely improved my calendar responsiveness. Also sorted out some odd defaults whilst not loosing the account settings. – GlennG Feb 8 '16 at 10:29
2

I solved my slow calendar by turning off Birthday calendars, Holiday Calendar, and Siri Found in Apps Calendar in the Calendar preferences.

I noticed an immediate improvement in speed. I restarted Calendar and the speed improved even more.

I suspect the slowness came from the birthday calendar feature. I have 5,787 contacts and that causes slowness elsewhere. I noticed Calendar app RAM usage went from about 300MB to about 100MB after turning off the special calendars.

Stefan's answer to Close Calendar.app, go to ~/Library/Preferences/ in your home folder and delete com.apple.iCal.plist helped initially, but things got slow again and another delete of the plist didn't help.

calendar preferences

0

A Genius appointment at an Apple Store did the trick.

Unfortunately the man helping us is not sure what he did precisely that worked. He is sure it was some kind of preference, cache, etc file that he deleted. But he tried so many things that we are not sure exactly what did it.

He also perished the logs on the Console.app but never got a clue as to what caused the glacial slowness.

But work it did. Day-and-night comparison. Calendar works zippy fast now.

Sorry that I don't have a specific solution. I'm posting this Answer only to communicate that anyone else suffering this problem should have some hope that they can fix this problem on their Mac. It is a client-side problem, not a server-side Apple-controlled problem.

Be very sure to have a good backup (or two) before experimenting.

0

This is not an answer, but perhaps a hint in the right direction. I have 2 calendars syncd with my iCalendar app: One is iCloud and it's fast, the other is an exchange calendar and it has the beach ball issue.

Maybe it's an exchange issue?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .