2

I have a late 2012 Macbook Pro that came running Mountain Lion out of the box. I have used Mail and Messages with my various Google accounts since I purchased it, but never Calendar. When I checked the Calendar option all I got was the header for where the calendars should be.

I cannot see any calendars on that account, create/view/edit events, or anything. My sync settings on the Google side are just fine as it works on other devices. Last night I took it a step further and created a new user account on my laptop and first thing I did was connect my Google account. Everything worked.

I have tried deleting the Calendar cache files, preferences, accounts, and pretty much anything short of the app itself. I even went ahead and cleared out my Keychain of anything relating to that account or Google in general. As a last ditch effort, I did a full clean up and reset of the SyncServices system.

Short of painstakingly comparing the two accounts I have no idea what could be causing this problem. There are no user specific applications or extensions running on my machine, and I've performed no "under the hood" tweaks to Mountain Lion.

Does anyone have any idea where I should be looking for a cause? I haven't found anything like this problem online yet, and I definitely don't want to migrate my stuff to a new account.

Key points:

  • Google Calendars do not sync at all to my primary user account.
  • I've tried multiple Google accounts.
  • Only a new user account in Mountain Lion is able to connect.
  • All SyncServices files and all Calendar files have been wiped and recreated to no effect.
0

I actually fixed my problem by deleting and re-creating my user account. I chose to keep the home folder in place and used it as an existing folder when I created the replacement account.

While I was troubleshooting everything I was monitoring the logs and saw no error specific error messages. The only thing that looked suspicious was a message about CalendarAgent returning status 4. I wasn't able to find a reference for that status message.

If I understand it correctly, the problem would had to have been in the /var/db/ directory in order to get fixed by an account deletion.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .