5

Bought a brand-new 2023 MacBook Pro 14 inch running Ventura 13.2 (updated from 13). It intermittently disconnects from the internet. The issue manifests in one of two ways: either there's an exclamation point on top of the WiFi 'pie' in the menu bar, or there's no indication at all but sites don't load. Either way it usually reconnects within around 10-20 seconds.

I have my iPhone X (iOS 16.3) and my previous laptop (2015 MacBook Pro 15 inch running Monterey 12.6.2) working fine on the same network. The router being used is an Adtran C424G.

While I'm no networking expert, there's a lot of crowding of SSIDs nearby and I've read that that can be a problem. But then I don't understand why more of my devices don't have a problem with it.

When I first set up the computer I installed a VPN and Little Snitch before connecting to WiFi for the first time. Thinking that might have messed with things, I then factory-reset the machine, but the issue persists. I have followed some of the steps here and here, including deleting the network preference files and disabling AirDrop, forgetting and re-adding the WiFi network, restarting my computer, restarting the router, using 2.4Ghz instead of 5Ghz, safe mode, etc.

I've called both Apple and my ISP. No dice.

I cannot reproduce the issue when I use my phone as a hotspot. Also, when I tried the laptop on a different WiFi network, I was unable to reproduce the issue, too. I'd be tempted to conclude that something is wrong with my WiFi network but again it works fine for my other devices so I'm left where I started.

Update: When I click on the WiFi 'pie' with the exclamation point I can expand the error message and it says "No Internet Connection — Your Mac successfully joined the Wi-Fi network, but cannot reach the internet. If this is your Wi-Fi network, try restarting the modem and router, or contact your ISP."

Update: Ran pings over WiFi hotspot (iPhone) for ~9 hours over night, could not reproduce the issue there.

1

3 Answers 3

4
+100

I believe the issue is related to similar issues being reported about Mac mini M2 Wi-Fi issues in the Apple Community discussion forums.

It seems there might be an issue related to 5Ghz connections related to AWDL (Apple Wireless Direct Link) stuff on the system.

It seems like the “solution” is to either connect to the router only via 2.4Ghz or disable AWDL (Apple Wireless Direct Link) on the problematic device. AWDL is what is used for AirDrop, AirPlay, Handoff and other “magic” connectivity services and such.

Details below.


Here are the devices you are using and their Wi-Fi specs.

Note how the 2015 MacBook Pro and the iPhone X is 802.11ac and so is the Adtran router. And how the 2023 MacBook Pro is 802.11ax. I believe that is the issue; that the 2023 MacBook is having issues connecting at 802.11ac on 5Ghz.

The “solution” (ideas?) presented by the user named “hanlanx” there are as follows:

  1. Create two separate networks for 2.4Ghz and 5Ghz: “Just separate my wifi network from shared SSID into 2 standalone SSID, 2.4GHz only and 5GHz only. Now manually connected to "2.4 only", it works perfectly without any problem, the "5 only" somehow works, but not stable, many packages are getting lost, get some big swing on the chart when doing a speedtest.net.”
  2. Disable AWDL: You would do this by running this command in the terminal sudo ifconfig awdl0 down (you can re-enable it with sudo ifconfig awdl0 up) and see if that clears it up. FWIW, AWDL is not Bluetooth but rather a peer-to-peer Wi-Fi protocol developed by Apple for things like AirDrop, AirPlay and the Universal Clipboard. More information on this great site Owlink (Open Wireless Link) dedicated to deconstructing and documenting Apple’s AWDL protocol.

I think both of these are viable items to test since they are both easy to handle and reversible. I would personally test disabling AWDL and see how that works. I mean, you won’t be able to AirDrop or use Handoff with that 2023 MacBook Pro but at least you can see if that clears things up. And if it makes no difference? Easy to undo with a basic sudo ifconfig awdl0 up command.

And for that Adtran router, here are instructions on how to control and tweak them 802.11 settings. I would see about disabling the 5Ghz network completely or tweaking the accepted protocol to be 802.11n only or even 802.11g only.

The 802.11 settings panel for the Adtran router.


All that said, maybe the best long-term solution is to get a real router that works better with 5Ghz 802.11ax Wi-Fi 6 connections.

But I believe that the ultimate solution here would be to set that Adtran router/modem into bridge mode so it is just a modem and then purchase a real/dedicated router to the setup that is more friendly with 802.11ax connections. The reality is ISP provided combo router/modem devices stink. Just forget about it and get a real router.

6
  • Don’t disconnect awdl. That’s the Bluetooth interface. This will have no effect on WiFi reliability.
    – Allan
    Feb 5, 2023 at 21:13
  • Testing what? You’re disabling a BT interface in macOS. You’re not powering down the radio. What exactly is going to be ascertained by disabling an unrelated interface in the operating system?
    – Allan
    Feb 5, 2023 at 21:17
  • @Giacomo1968 Thanks for your research, this look promising. I had already separated out the 2.4ghz and 5ghz frequencies into different SSIDs but have now additionally disabled the 5ghz frequency altogether. (I once tried the 2.4ghz frequency with no luck but hadn't disabled 5ghz at the time.) "I would see about disabling the 5Ghz network completely or tweaking the accepted protocol to be 802.11n only or even 802.11g only." Tweak the protocol on the 5ghz or the 2.4ghz? Feb 5, 2023 at 21:35
  • 1
    @Giacomo1968 Your suggestion to disable 5GHz altogether while using only 2.4GHz did the trick for me and provides an instantly working (albeit temporary) workaround. Connecting to the wifi can still be tricky, but once it's connected it stays connected and I get very little packet loss. Getting a better router as a long-term solution makes sense, too. I'm awarding the bounty to you. Feb 7, 2023 at 19:55
  • 1
    @Giacomo1968 I have a 2023 MBP and ran into a similar issue with my Wifi. I have a router + extender setup in my home, the extender is in my office to connect to my PC via ethernet since PC has no WiFi. I had the router set up with the 2.4GHz and 5GHz unified under 1 SSID but for some reason my MBP was happy with the main router but on the AP it connected but with "no internet". Disabling the 2.4GHz and setting 5GHz for the connection while using 2.4GHz for the AP<->Router worked The new odd wrinkle is I have an ethernet<->USB-C dongle and it too connects but won't see past the extender
    – TxAG98
    Nov 23, 2023 at 14:22
3

Apple has exhibited this problem for donkey’s years now. A device driver engineer I worked with (I was on the hardware manufacturing side prior to going into management) explained that Apple drivers aren’t as tolerant as other drivers. In this case, the Signal to Noise threshold may be too “conservative” and will drop a connection due to signal quality. This is why you will often see a MacBook with Bootcamp have WiFi issues with macOS and seem to work fine on Windows. More commonly, you’ll have WiFi that seems to just “break” after an update or upgrade.

That’s just a small sampling of issues.

The question is… how do you solve it?

Get a better Access Point

Yes, this is counterintuitive. However, I’ve done extensive testing and found that Apple products work best with Enterprise Grade networking gear.

Does this mean you have to get rid of your router?

Not necessarily. As described in the previous link, you can simply get a dedicated Access Point (AP). You can disable the WiFi on the router (based on bargain bin chips) and just allow it to serve as your DHCP/DNS, firewall and gateway between your network and the Internet. The higher grade APs will handle your WiFi needs.

Why does an Enterprise grade AP work?

While I'm no networking expert, there's a lot of crowding of SSIDs nearby

It’s not just your MacBook’s AirPort adapter (WiFi) that has to find a suitable channel with sufficient signal strength, the WiFi chip in the router must also content with channel crowding and trying to overcome all these rogue signals. That retail “router” is only capable of so much.

Getting a dedicated AP centrally placed with high quality chips and antennae that allows for higher signal power (more power equals better signal), you will be able to overcome the problem of the tight thresholds the macOS driver (kexts) preventing you from having a stable connection.

2

What helped me was going to "Network" settings, right click Wi-Fi and "Delete Service…". After that click the "…" in the right bottom corner, and do "Add Service" — pick Wi-Fi there. Worked perfectly after that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .