2

Setup:

  • Computer: Macbook Air 13-inch (early 2014) 1.7 GHz Intel Core i7, 8 GB, running OS X El Capitan. Using DHCP & automatically configuring IPv6
  • Router/modem: Netgear N300 Wifi cable modem router, Model C3000
  • ISP: Time Warner Cable

Problem:

Wifi stays connected, but ceases to have internet access constantly. I can regain internet access by either cycling the wifi on and off from the top bar, or by running "Diagnostics" in the "Assist me" section of the Network System Preferences.

When I run Diagnostics, the Network Status shows up green for Wifi, but red for wifi settings and everything below that. The actual act of running the diagnostics fixes the problem.

I've tried power cycling the router, the computer, and the cable box, as well as renewing the DHCP lease. It seems to improve the length of time between internet disconnections, but they still happen somewhat often.

  • So you are using DHCP and you tried renewing the DHCP lease? :) – emotality Sep 20 '16 at 18:12
  • Yes I've tried renewing the DHCP lease, and I'm still losing internet connectivity intermittently – NYCmac2014 Sep 22 '16 at 16:06
  • Is there something else I can try? – NYCmac2014 Sep 22 '16 at 18:39
  • This happens to me constantly. With Time-Warner cable wifi router and with MacBook 2015. If I have an Adobe video stream it will keep working; but none of the web pages work. I basically have to recycle the wifi every 5 minutes if I want to use a MacBook with it. Lenovo laptop, android phones, and even iOS tablets and phones have no problem. BTW, macbook also does not really turn off its bluetooth when you turn it off so irritates the bluetooth headset connecting with phone. Have to close lid to get it off! I guess macbook just isn't tested in real world, Time-Warner wifi. – maxweber Oct 21 '16 at 1:30
1

What version firmware is present on the net gear? Does this also occur if you are hardwired in? Can you disable the N band temporarily to see if that changes anything?

  • The firmware version is V2.02.08. It doesn't appear to happen when I'm hardwired in. How do I go about disabling N band? – NYCmac2014 Sep 27 '16 at 2:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .