5

I don't need the keyboard backlighting on MacBooks, and yet every time I turned it off, it's automatically turned on again after waking up from sleep / reboots.

How do I turn off backlighting permanently on MacBooks running macOS Big Sur?

Edit: Add my current settings in Sys Prefs:

enter image description here

  • Yes, Adjust keyboard brightness in low light is unchecked.
  • Backlighting is always automatically turned on after the Mac wakes up from a sleep of more than 6 hours, the keyboard brightness won't change as long as I keep using the Mac / the Mac is not put to a sleep for more than a few hours.
  • This bug exists in Catalina too, before I upgraded to Big Sur.
2
  • Is this just a personal preference of yours or is there some specific reason why you want this?
    – idmean
    Dec 17 '20 at 16:47
  • Yes, I guess it's a personal preference. :)
    – Teddy C
    Dec 18 '20 at 1:11
5

You need to uncheck the "Adjust keyboard brightness in low light" setting in the "Keyboard" pane of System Preferences. Then, adjust the backlight to zero by pressing F5 (or tapping the setting on the Touch Bar).

Image

(image from https://support.apple.com/en-us/HT202310)

1
  • Thanks for the answer. It doesn't work on my MacBook Pro and I don't know why. See the updated question. :)
    – Teddy C
    Dec 17 '20 at 13:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .