1

The behavior of my Notification Center is inconsistent and unpredictable; when trying to swipe left within applications, it will sometimes expand from the right of the screen and steal focus from important work I was in the middle of. This is infuriating, as I then have to manually set focus back to the application I was working in. It is a detriment to productivity and sanity.

How can I disable this "feature" entirely? I never want to see it again. Is there an On/Off toggle in Preferences somewhere that I am missing?


macOS Big Sur: v11.5.2

1
  • Turn on Do Not Disturb. For instance, press and hold the Option key and select the Notification Center icon.
    – lhf
    Feb 2, 2022 at 20:54

1 Answer 1

3

There doesn't appear to be any way of completely disabling Notification Center, however, we can get close.

We're able to disable the Notification Center swiping gesture by going to:

System Preferences -> Trackpad -> More Gestures -> Uncheck "Notification Center"

enter image description here

Then, in System Preferences -> Notifications & Focus you can adjust the notifications you're receiving to further cut down on distractions when Do not Disturb is not on.

Hope this helps.

1
  • This accomplishes exactly what I need it to, though it does seem silly that the tool is still hiding there, taking up resources (however small they may be). Anyways, this will keep it out of my face. Big thanks.
    – muad-dweeb
    Feb 2, 2022 at 22:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .