0

Okay so I don't have an official Apple store in my country and my keyboard and batteries were giving me trouble. During the replacement process, as I was taking out my original keyboard, I slightly cut the JC02 AMS983 flex cable that connects the logic board to the Touchbar display. I was devastated.

But I got a replacement online (the one that says A1707) and ordered 3 of them just in case one was faulty. However, where I had still been getting the Touchbar options in settings with the broken cable connected, I now have no options related to the Touchbar on my Mac. The software seems to think that this is a Macbook without the touchbar. I even tried switching to another new cable but still no luck. What could be going wrong and how can I fix this? I have three replacement cables and they look identical to the original and even have the same part number.

Could there be some sort of system integrity protection at play, blocking the new part since it wasn't installed by Apple? I have already tried resetting SMC and NVRAM etc. and starting in Safe Boot mode and running First Aid on my disk.

cable on the right is my damaged original and the one on the left is the replacement

TLDR: Accidentally cut my Touchbar display cable, after replacement Mac OS seems to think this is a Mac that shipped without the touchbar. Help? Going to Apple is not possible in my country.

Edit: Just found this proof of Mac trying to communicate with the Touchbar display in the Console app. The touchbar was working flawlessly (well, as flawlessly as it worked out of the box) before I snipped the cable. Perhaps this could hint at something:

Console app showing mac saying display is not ready

4
  • Then the touchbar probably has to be replaced. If you accidentally cut the cable, there’s a good possibility that you shorted something and Apple is known to put a high voltage backlight pin (20-50VDC) next to a data pin (1-3VDC) on the LVDS cable on that same MacBook. If it’s not seeing it...it’s toast. – Allan Nov 6 '20 at 0:04
  • But I cut it when the battery and everything else was disconnected so that's probably not a possibility? – Shahraiz T. Nov 6 '20 at 0:59
  • Are you certain the new cable is seated perfectly and all contacts are making connection? Software wise, have you tried resetting the SMC and NVRAM, and booting into recovery mode? (It's also not impossible the cables are all simply bad/made incorrectly.) – negacao Nov 6 '20 at 13:35
  • @negacao Yes, I triple checked all the cables and connectors and made sure everything was making full contact and was seated correctly. I also made sure not to over tighten the cable connector covers because I've read that it can cause poor contact. – Shahraiz T. Nov 6 '20 at 21:46

You must log in to answer this question.

Browse other questions tagged .