I'm on a new 2019 MacBook pro 13”. The TouchID fingerprint sensor is working. But my touch bar has gone completely blank. I tried restarting my MacBook Pro but it did not help.

enter image description here

I've also done a factory reset, SMC, NVRAM/PRAM and an Apple diagnostics, hoping to fix the problem but it did not work.

After re-install macOs, I was able to see touch bar configuration on System Preferences -> Keyboard menu:

enter image description here

I am not able to see touch bar option and it is completely dark black.

I tried resetting the touchbar through the terminal by using the below syntax:

  • sudo pkill “TouchBarServer”
  • sudo pkill "Touch Bar Agent"
  • sudo pkill ControlStripAgent

I have tried to verify whether they are running by using below command and could not find any process running.

  • ps -A | grep -i "touch bar agent"
  • ps -A | grep -i "controlstrip”

I can see the control strip and touch bar server is running in activity monitor:

enter image description here

enter image description here

I could see this is a common issues across mac book pro and customer don’t have any proper fix for it.

  • Is it blank when you boot into the Recovery OS? It should show a "esc" button. If not, did you try to boot into Apple Hardware Test? What are the results?
    – Joy Jin
    Commented Apr 27, 2020 at 12:14
  • How new is the MBP?
    – Jash Jacob
    Commented Apr 27, 2020 at 15:43
  • @JoyJin, can you please guide me with steps or links which will help me to Apple Hardware Test.
    – prav
    Commented Apr 27, 2020 at 16:36
  • In addition to above, I am wondering why Touch Bar agent is not running on my Mac. It would be helpful, if you can help to start running "Touch Bar Agent Process".
    – prav
    Commented Apr 27, 2020 at 16:49
  • @JashJacob, I bought this MacBookPro in Dec'2019.
    – prav
    Commented Apr 27, 2020 at 16:51

3 Answers 3


Your Touch Bar has failed and you need to have it serviced.

The TouchID fingerprint sensor is working. But my touch bar has gone completely blank.

This very statement has come up a lot, even here on Ask Different. The touch bar and the fingerprint sensor are two completely different things - a very thin display and a fingerprint sensor - covered by a single pane of glass. It’s a very common misconception to believe that the whole thing must be working because the fingerprint sensor is functional.

Think of the Touch Bar as a display, not unlike the display on an iPhone with the fingerprint sensor (i.e. iPhone 7+). Many times the LCD would malfunction in someway, but you were still able to unlock it with the fingerprint reader. The same thing is happening here.

You’ve done all the proper steps to diagnose it, but unfortunately, you’ve arrived at the only conclusion left - it’s dead.

  • Is there a way to disable Touch Bar completely? I'm certain my Touch Bar is dead, but I can still work with this laptop, just that a lid close now causes the kernel to panic and restart/shutdown. I'm ok without the Touch Bar, just would like to be able to close the lid and let my MBP sleep. (2016 15 MBP, Ventura)
    – dixitk13
    Commented Jul 5 at 16:59

I ran into this problem (completely blank touch bar) and none of the potential solutions here worked for me. On another site I found this, which did work – hopefully it can help someone else in the same situation:

sudo killall ControlStrip

For anyone coming to this post from a web search, this is what worked for me:

  1. Shut down your Mac.
  2. Press and hold the power button for 10 seconds, then release the button.
  3. Wait a few seconds, then press the power button to turn on your Mac.

Source: https://support.apple.com/en-us/HT201295

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .