Due to a series of unfortunate events, my 2018 15” MacBook Pro found itself out of battery and with screen brightness set to zero.

I should also mention that I have FileVault full disk encryption enabled, so there’s the intermediate boot step that asks you for your password before fully booting the computer, running apps and (presumably) whatever it is that draws the brightness button in the touchbar.

Basically, when the computer booted, the screen looked like it was completely blank, and the only thing on the touchbar was the Esc key (in particular, no brightness button). I initially panicked, and tried to reset the SMC, but it made no difference. After a while, I figured out that only the backlight was off, so shining a light into the display allowed to figure out what was being drawn on the screen, and from there I got the computer to boot — with enormous difficulty.

However, the process would have been much easier if I could have reset the brightness to a more usable level.

Given that the brightness button on the touchbar is unavailable before boot, what can I do to adjust screen brightness before the computer fully boots?

  • Can you plug the computer into an external display?
    – JBallin
    Commented Feb 5, 2019 at 2:04
  • Have you reset non-volatile memory (press command-option-P-R throughout reboot)? I believe screen brightness is one of the stored settings. support.apple.com/en-us/HT204063 SMC reset procedure is a different process on the 2018MBP as far as I know. Commented Jun 11, 2019 at 18:40

3 Answers 3


I found this issue with the touchbar not showing anything happens only if you've file vault on.

After booting my system I just assumed it was at the login screen and asking for password. After entering the password it logged me in and the touchbar controls appeared again.


I just encountered the same problem.

And this is the window. It's really hard to read text with the lowest brightness. I hope this image helps someone who has the same issue.

enter image description here

In this screen, you can't select the checkbox by tab key. You have to use mouse cursor that is located at the top-right corner.

The problem was solved by clicking the Previous button in my case.

By the way, the external display wasn't detected in this screen.


I had the same problem and it was unbelievable, it's so weird that they didn't think about this edge case. The way I resolved was pressing the right arrow and enter then I typed the password.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .