Since the 10.15.5 Catalina update, file dialogs in my system are extremely slow. It can easily take a couple of minutes to be able to save something to the disk. Never had a similar problem before.

Ran a disk check, made sure that I have free disk space (more than 400GB).

Otherwise, the machine is running smoothly, without any other issues.

Tried googling around and found out that there was a similar issue back with Sierra. Tried to apply the proposed fixes, but to no avail.

In Safe Mode the problem doesn't appear to persist.

Any suggestions would be greatly appreciated!

Machine specs: Mac (Retina 4K, 21.5-inch, 2017), 3,4 GHz Quad-Core Intel Core i5, 8 GB 2400 MHz DDR4, 1TB Fusion Drive.

Update: No finder extensions installed. No OneDrive/Dropbox/anything like that.

    kextstat | grep -v com.apple
    Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
  102    0 0xffffff7f80f2d000 0x6c4000   0x6c4000   com.realtek.driver.RtWlanU (1830.32.b13) E254FC27-6491-3BC2-BBE8-1B529EA778CD <57 18 6 5 3 1>

Update 2: It takes roughly 90 - 120 seconds to a Save or Open dialog to become active. While it's stuck, the CPU usage by the process gets close to 100%. Doesn't matter the application I'm using - QuickTime, Pages, Microsoft Word, Photoshop or Safari

Trying to save an image Trying to upload the image here

Update 3: Booted up in the recovery mode and reinstalled Catalina keeping all the computer data. The problem persists

Update 4: Installed BitDefender Trial version in order to make sure there is no malware/virus/whatever on my machine. 90 minutes later - nothing found, but the problem persists.

Update 5: Configured a new administrator account on the Mac. While configuring it, unchecked all iCloud features - the problem doesn't reproduce using that account. Updated the new account with iCloud settings (photos sync, documents sync), the problem doesn't appear.

  • Since safe mode is fine, do yo have anything link onedrive, dropbox or something that adds finder extensions ? review your apps & also system preferences > extensions. Also what is the output of kextstat | grep -v com.apple
    – anki
    Commented Jun 5, 2020 at 12:46
  • @ankii I've updated my question - no Finder extensions installed, don't use Dropbox or OneDrive or anything like that. I've also posted the output of the command in the question.
    – WeRReD
    Commented Jun 5, 2020 at 12:56
  • File dialogs have traditionally been slow if there's a disk that has to wake up from sleep, or network shares that take time to connect. I don't know if this has been remedied in newer OS versions. Do you have any slow hard drives or network shares?
    – benwiggy
    Commented Jun 5, 2020 at 13:18
  • @benwiggy I do have a Synology NAS in the network, which is not mounted. It appears in Finder under 'Locations' though. I don't have any external drives connected to the machine. Otherwise the computer is running well without any other issues. Copying operations are as fast as they were before the update.
    – WeRReD
    Commented Jun 5, 2020 at 13:21
  • discussions.apple.com/thread/6159839 nice find the culprit process!
    – anki
    Commented Jun 5, 2020 at 19:24

4 Answers 4


I spent about a year working with Apple technical support on something that sounds just the same. The good news is that, assuming your problem is the same as mine, there is an easy fix. The challenge in diagnosis is that some interaction between iCloud and the Finder appears to be involved. iCloud's involvement is why problem persists across reinstalling the system, etc.

They fix was to delete either the dyld shared cache or the XPC cache. Unfortunately, I can't remember which it was and can't find my notes from then. But, since they are both just caches, there is no harm in deleting either or both.

The best way I found to do it is to download the Onyx app (free from https://www.titanium-software.fr/en/index.html). Under the "Maintenance" tab withing Onyx, you'll see the option to delete either or both of those caches. Do so, reboot and see if your problem is fixed. Once I did this, it fixed the problem entirely and it hasn't reappeared in over 2 years. There is probably a way to do this from the Terminal (indeed, Onyx is mostly just a wrapper over command line functionality), but Onyx worked great for me. I hope this helps you.

  • Thanks for the suggestion. I installed Onyx, ran all the scripts under maintenance, restarted the computer, but unfortunately the problem persists.
    – WeRReD
    Commented Jun 6, 2020 at 7:05

You have ascertained that the problem does not occur in a new user account. That means something in your original user account Library is causing the problem.

It could be some software running in the background, like a Login Item, or LaunchAgent; or some preferences that are corrupt, or initiating something undesirable.

  1. In System Preferences > Users & Groups > Login Items, deselect everything, and test each item in turn.
  2. Check the contents of <user>/Library/LaunchAgents. Remove anything there and restart.

If those don't improve matters, then it's possible some corrupt preferences may be causing the issue. You'll have to trawl through <user>/Library/Preferences, and test the problem after removing some of the com.apple.xxxx.plist files. I suggest removing them all; test the problem. If things work, then replace half of them; test the problem. If things don't work, remove half of the ones you put back. And so on.

As the problem relates to com.apple.appkit.xpc, you could try removing the com.apple.xpc.activity.plist files, and similar, first of all.

This may be tedious, and it's possible that the problem lies in some other part of the User Library folder, but each step narrows it down further and further. You could try deleting all user Caches, too.

The alternative is migrating to a new user account ("'slash and burn"). That's fine, but if you do that every time you get a user account problem, you'll end up with a string of user accounts, and files looking for different paths, and permissions issues, etc.

  • Thanks for the suggestion, but unfortunately it didn't help. There are no Login Items for the user, there were a couple of Launch Agents which I've removed. Additionally, removed all com.apple.xxxx.plist files from the directory - the problem persists, no change in behaviour.
    – WeRReD
    Commented Jun 6, 2020 at 16:43
  • OK, but it must be something in the user Library, because another user account works fine.
    – benwiggy
    Commented Jun 6, 2020 at 17:06
  • Still trying to pinpoint the culprit. Probably will just going to give up and stick with the new user account if I won't be able to identify the root of the problem.
    – WeRReD
    Commented Jun 7, 2020 at 7:55

After trying to identify the source of the problem for a long time, I decided it's not worth it and completely migrated to a new user account on the same machine. While using the new user account there are no signs of the problem.

I also just realised that the produced the same issue for my MacBook. Will have to migrate to a new user on it too.


I deleted /Library/Cache files and then removed all files in /Library/LaunchAgents. Solved my problem and file open dialog is very quick now. seems to have resolved the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .