1

I updated to Catalina 10.15 about a week ago, and I noticed the Time Machine backups do not seem to work properly. Yesterday I thought I'd try to make it work again, but the problems I face are so weird!

The backup goes through the "Preparing backup..." with no errors, and then it starts copying files. When it has gotten about two thirds of the way through the 17 GB (I'm guessing it's so large because of the update) it just quietly stops, without any error message. If I check for the backupd process in activity monitor, the CPU usage is at 0.0 and never increases. Also the drive will stop spinning after a while, so clearly nothing is written. I figured out how to print the log from the process in a terminal, and there are no messages when the process shuts down.

  • I tried sudo sysctl debug.lowpri_throttle_enabled=0 but it doesn't make any difference.

  • I have reset NVRAM and SMC. No change.

  • I ran a First Aid on the backup drive. No issues.

  • Deleting .iprogress files to start over does not solve the problem.

  • When running in safe-mode, the backup becomes smaller and it stops earlier. But the issue remains.

I'm using a 2018 MacBook Pro, 13 inch, with Catalina 10.15 (as mentioned), and I have two external hard drives for backups (one is encrypted and one is not). They have both worked fine with Mojave, but now I have the same problem with both.

Edit 1: I updated to Catalina 10.15.1 and the problem persists.

Edit 2: Since I am getting so little response, let me ask some more specific questions.

  1. How can I tell which file(s) is being copied when the backup process freezes? If I know which file, perhaps I can just delete it and the process will run.

  2. Can I restart the backup from scratch? Perhaps if I rename the folder which holds the backup on the disk, Time-machine won't find it and start from scratch. And if I then want to access my old backups I can take back the previous folder name? Could this work? And which folder should try to I rename?

Edit3: I have recently started to believe that there is some issue with backupd initiating too many threads. Whenever it freezes it shows 67 threads in the activity monitor.

  • MacBook Pro 2018 If you delete the .iprogress the backup should start over however my experience has been that it just freezes again so that did not work either. I am experiencing the same problem with both 10.15 and 10.15.1. I have tried just about everything short of completely starting over with a fresh install of Catalina which I am not sure would do any good. It seems to stop at different points. On one occasion I stopped and restarted the back and it finished, however on subsequent trial this did not work. I have tried three different backup drives and all failed. – Roger Emnett Nov 4 '19 at 3:12
  • I am not the only one! I have also tried removing .iprogress files without any improvements. And yes, my backup has also stopped at different points, but most of the time it is about 2/3 in. One funny thing, the backupd process seems to always shows 67 threads in the Activity Monitor when it freezes. Same for you? – stack-delay Nov 4 '19 at 12:52
1

Okay, my Time Machine backups work now, and I can post this answer to my own question.

To print out what files are currently being copied there is a nice command in the terminal:

sudo fs_usage -wf filesys backupd | grep HFS_update

Doing this I could see that my backup froze at certain files, and CPU was at 0.0 usage. However, even after it had frozen, intermittently it made small steps of progress before freezing again (as I could tell from the terminal printout). And even though CPU usage showed 0.0, the total number of CPU hours were very slowly creeping up. So there was some activity in backupd, but so little it rounds to 0.0. Thus I left the computer on over night, and in the morning it had finished. It took 14 hours to finish, including several hour-long pauses when no files were written to the backup drive.

I was using Catalina 10.15.1, but using the newly released 10.15.2 for my second backup disk I can tell that the problem persists. I then reformatted the second disk to see if that would make it any faster. But no, it takes even longer to create a new backup (20.5 hours).

However, after one painfully slow backup has finished it seems to work normally, with much shorter backup times.

Read more here: https://eclecticlight.co/2019/11/11/time-machine-and-backing-up-in-catalina/comment-page-1/?unapproved=42377&moderation-hash=3183957ce67228fdfbd8a9b757b038dc#comment-42377

0

I have experienced the same issue with a MacBook Pro 2016. After updating to Catalina 10.15 it succeeded with a couple of backups, but then it got stuck. I have several disks with Time Machine backups, e.g. one LaCie Portable 4TB and one 5TB. I reset both and made fresh backups. Both got stuck when 20 GB and 30 GB remained respectively. After stopping and restarting the backup operation, the (initial) backups succeeded on both disks.

However, now the backup gets stuck on "Preparing backup". I have stopped and attempted to delete the .inProgress file, but that does not succeed.

I have run the disk tool and checked both my computer's disk and the external disk drives, but no issues were found.

I also have a number of disks where I have cloned the disk using ChronoSync. No issues with that and I have verified that I can boot from the cloned disks and the systems seems to be running correctly.

Besides the TM issue, a couple of times the computer has get stuck before I try to enter the password. Only thing to do then is to force shutdown the computer (yes, I have waited a couple of hours first...)

  • I can't manually stop a backup once it is stuck. Pressing the little cross to the right of the progress bar does nothing. – stack-delay Oct 30 '19 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .