I was in the process of restoring my Mac Mini 2018 running macOS Catalina 10.15.1 to an earlier Time Machine backup encapsulating the latest version of macOS Mojave via macOS Recovery, when the process failed. I got the message:

An error occurred while restoring from the backup. Try restoring from a different backup or reinstall macOS and then transfer your information from a Time Machine backup using Migration assistant.

I then restarted the Mac, and tried to enter macOS Recovery (+R on boot). I saw the "spinning globe" icon for about 4 minutes, but then it gave the error:


I have since reset the NVRAM (++P+R) but I continually get the "-1008F" error when trying to access macOS Recovery. However, in this Reddit thread regarding this nominal issue for the macOS Catalina Beta, they suggest to try another Recovery key combination (++R on boot), and this indeed gets me into some sort of Recovery mode where I'm first asked to enter my Apple ID, and I can afterwards see the usual Recovery options like Disk Utility, Reinstall MacOS, Restore from Time Machine backup, etc.

However, I am unsure on how to proceed from this point. As mentioned, my previous Time Machine restoration failed from macOS Recovery (the backup is located on a Synology NAS on my network; I have an additional concurrent backup on another Synology NAS which I haven't tried yet).

Furthermore, according to some sources I found on the net when searching for the "-1008F" error, it can be indicative of hardware failure and some people seem to have had hardware parts replaced. I did notice that when I entered macOS Recovery the first time, it was lingering a very long time on the state: "Examining available disks...".

When checking Disk Utility, I have two Mac HD Partitions apparently since installing macOS Catalina: Macintosh HD for the OS partition and Macintosh HD - Data for user data. Since macOS Mojave doesn't use this setup, do I need to "merge" these partitions to successfully restore from the Time Machine backup or reinstall macOS Mojave from scratch? I wonder this because when I navigate to the Time Machine backup process, it asks me which partition to restore into – and I can select both the Macintosh HD and Macintosh HD - Data partitions. This doesn't feel right, as macOS Mojave uses one partition for both OS and user data.

If I indeed need to "merge" the two partitions (e.g. by reformatting them into one "Macintosh HD" partition), how do I do that? A user in this Reddit thread regarding the MacOS Catalina beta suggests to "Erase the APFS container and format it again as APFS", but I don't understand what the user means by the "AFPS container". I don't see a single container encapsulating both partitions, rather they appear like two separate things seen in the images below:

enter image description here enter image description here

To make a long story short: how do I best resolve this problem and restore my Time Machine backup to my macOS Mojave system from the now broken macOS Catalina system?

Do I need to reformat the drive first, and can I then restore from my Time Machine backup – or should I install a fresh copy of macOS Mojave and then attempt restoration via the Migration Assistant?

  • Macintosh HD and Macintosh HD have been part of a APFS volume group (which AFAIK doesn't exist in Mojave). The volume group and some other volumes (VM/Preboot/Recovery) reside in a Container. Check diskutil ap list.
    – klanomath
    Commented Nov 11, 2019 at 11:40
  • Ah, there is two APFS volumes under a Container visible if I click on the "View"-button and choose to display "All". The SSD/container/volume tree was collapsed. I spoke to Apple support just now and they suggested me to erase the entire SSD which created a new container and APFS volume. Currently reinstalling MacOS Mojave by using SHIFT + ALT + CMD + R on boot, and hope to be able to restore from Time Machine with Migration Assistant. Hopefully I will also be able to create a new Bootcamp partition with this setup. Will give an update once I know more.
    – P A N
    Commented Nov 11, 2019 at 12:38
  • My advice would have been the same (as Apple's support) :-)
    – klanomath
    Commented Nov 11, 2019 at 12:43

1 Answer 1


I was in contact with Apple's support for this issue, and it was ultimately resolved although a bit tortuous.

There are several modes of MacOS Recovery, accessible by holding different key combinations as described here.

Trying to access MacOS Recovery failed and gave the "-1008F" error every time I tried the MacOS Recovery modes "Reinstall the latest macOS that was installed on your Mac (recommended)" (+R) and "Upgrade to the latest macOS that is compatible with your Mac." (++R).

However, the mode "Reinstall the macOS that came with your Mac, or the closest version still available." (+++R) did work for me. From this mode, I was instructed by Apple Support to wipe/format the disk entirely clean using MacOS Recovery mode's Disk Utility and create a new volume (I'm not sure if this step is absolutely necessary). From there on, I could successfully install MacOS Mojave (the OS that originally shipped with the Mac).

Next arose the issue of restoring my system. My intention was to stay on MacOS Mojave instead of MacOS Catalina, but unfortunately it appears that when I installed MacOS Catalina the first time (before all this happened and I decided to go back to MacOS Mojave) – MacOS Catalina actually converted format of my Time Machine backups stored on my NAS from the traditional .sparsebundle format to the newly introduced .backupbundle format. I think this was disingenuous by Apple, because I had not been asked for this conversion to occur, nor did any Time Machine backup process once MacOS Catalina was installed ever move past the backup preparation stage since I had manually disabled Time Machine backup. In other words, MacOS Catalina converts your Time Machine backups to a new format without asking you!

The problem is of course that the new .backupbundle format of Time Machine backups cannot be identified by MacOS Mojave. According to Apple Support, Apple does for the time being provide a "secret" method to convert .backupbundle files back to .sparsebundle, but this is not something that they are announcing publicly because apparently they want all users to shift to MacOS Catalina. Rather than hassle with this however, I opted to upgrade to MacOS Catalina and try to restore my Time Machine backups from there instead.

Once MacOS had been upgraded to a clean install of Catalina, a had a new problem because the Time Machine backups were now identifiable but not restorable by Migration Assistant.app, the recommended Time Machine restoration application in MacOS. I believe the error message said something like "Could not open backup, file in use..." (paraphrasing). It turns out that there was an issue with MacOS/Migration Assistant not being able to open Time Machine backups stored on my Synology NAS devices over the network, even when trying different modes of SMB/AFP. The solution was to copy the .backupbundle files from the NAS onto an external USB/Thunderbolt drive, then mount the .backupbundle file by double-clicking it in Finder, and finally running Migration Assistant again. From thereon, I could successfully restore my files and system configuration onto MacOS Catalina.

The first lesson here is not to keep Time Machine backups only on NAS devices, because they are unsupported Time Machine destinations in Apple's view. Apple primarily supports Time Machine backups on external USB/Thunderbolt drives, and were not inclined to help me resolve the problem of reading the Time Machine backup on the NAS. I had to buy an entire new external drive in order to relocate the .backupbundle file and restore it, and I now intend to back up both to the external drive and NAS continually. The second lesson is to make copies of your Time Machine backups before upgrading to a new OS – I did not foresee that MacOS Catalina would convert or otherwise do things to my backup files upon OS upgrade without my permission!

Hope this is of use to anyone else running into this chain of issues after upgrading to MacOS Catalina.

  • excellent answer. I had same issue when downgraded Catalina to Mojave. Am I right that you still can't use standard apple+r recovery? I'm in the same shoes so interested if your system works perfectly without apple+r so you just use alternative method to access Recovery when needed?
    – laimison
    Commented May 10, 2020 at 22:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .