1

Since I upgraded to macOS Catalina this weak, the following features of Apple Mail no longer work:

  • Search
  • Flagged Mail
  • Smart Mailboxes

I have tried reindexing everything using Spotlight and also rebuilding the mailboxes, but neither of these things works. What can I do? This seems like a real mess-up by Apple.

1

In such events where a problem arises due to multiple reasons, answers look like troubleshoot efforts. Cleaning up the comments, here's what I did on Mojave for an IMAP account:

    • Back up the relevant folder under ~/Library/Mail/ and then delete the original folder associated with the troubling account.
    • Hide the ~/Library/Mail/ from Spotlight index using Spotlight Preferences -> Privacy and revealing hidden folders in Finder layover.

    Spotlight Privacy Folder Selection

    • Restart Mail and wait for all the mails to get downloaded. And remove the said folder from Privacy in Spotlight Preferences. Let the indexing be complete. If anything breaks, use the backup folder.
    • Do step one(backup) of above and take screenshots of Mail Preferences in case account specific settings like "rules" break down.

    • In Internet Accounts in System Preferences, remove the account. Wait for some reasonable time, and add it back.

    • Again if anything breaks(as OP says, smart mailboxes, not for me), replace the new folder under ~/Library/Mail/V6 with the backed up one.

| improve this answer | |
  • Thanks for posting these steps. Good for anyone who comes across this question. (I presume you weren't the one who downvoted my brief answer?) – Noldorin Oct 20 '19 at 14:26
  • No I didn’t. it came when I wrote my answer. We see answers recommending updates all the time. There, nullified it. I thought of doing so when I saw it, but waited for some comment from voter. – anki Oct 20 '19 at 14:42
  • No problem, I didn't think so. Anyway I will edit my answer to say I tried the steps mentioned in yours... not sure which to accept yet. Of course, my answer solved it, but yours is probably the more helpful to other people visiting! (Up-voted yours regardless.) – Noldorin Oct 20 '19 at 14:57
0

Annoyingly, this seems to have been a problem with the initial release of macOS Catalina that disappeared when I installed the just-released Catalina update and rebooted. I tried all the steps mentioned in @ankii's answer (some of which were formerly in the comments), and unfortunately they didn't work, although evidently they have worked for many people in the past for problems very similar to this. Perhaps Apple quietly fixed this issue with the latest Catalina update, or it was a combination of the update and some of the previously-attempted steps.

Hopefully between these two answers, others who come across this question should find their solution!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .