1

As an online shopper, I regularly use Amazon to purchase lots of stuff. When I reconcile my credit card spending, I use Mail.app to search all mailboxes for specific dollar figures (e.g. command-option F, then type 24.95).

Prior to Big Sur, finding dollar figures in Mail.app worked perfectly, whether the email messages resided "On My Mac" or on iCloud. However, since Big Sur, doing a global Mail.app search for numeric strings, especially with a decimal point, doesn't work reliably.

For example, I'll do a global search in Mail.app for 65.88 and I'll get one result from a locally archived message from years ago, however a very recent message in my InBox containing that figure is not found. When I do a single message search (command-F) looking for 65.88, the value IS found.

Unsurprisingly, using Spotlight delivers the exact same results.

Using mdutil, I've manually erased and rebuilt the Spotlight index, rebuilt my Mail.app mailboxes, deleted all ~/Library/Mail/V8/MailData/Envelope* files to force the Mail.app to re-import everything, and reinstalled Big Sur. I've also confirmed all my Spotlight settings to assure that Mail and Messages are included in searches, and that the volume where my mail resides is not excluded. Nothing worked.

I should note that I am using one SSD for macOS, and a separate SSD for my Home directory (c/o "Advanced Options" under Users & Groups). I've had this setup well before Big Sur, again, without any issues.

Interestingly, I tried using the Spark email app, which DID successfully find dollar figures without any issue. I suspect that Spark is not relying on Spotlight to obtain search results, and that's why it works. (I would use Spark, however it doesn't support local mailboxes.)

I've already sent Apple a report using the Feedback Assistant, and I can only hope something will get fixed.

Can anyone else confirm this issue with Mail.app on Big Sur? Any ideas on what else I can do?

2
  • Today I updated to Big Sur 11.1, hoping this would get resolved. Unfortunately, no dice. – Bill Cody Dec 15 '20 at 0:06
  • Update: I discovered that this problem is related to numeric string searches ONLY when they include a decimal point. Other numeric string searches work fine. – Bill Cody Dec 15 '20 at 2:07
1

I can confirm this is a real issue since Big Sur. I did talk with Apple Tech Support, she agreed it is a known issue. She told me to put problem in Feedback Assistance which I did a while back. I have not come up with any work around other then just searching for numbers to left of the decimal point as you mentioned.

In addition, various text and text strings are not found as well. Really want Apple to fix this asap.

0

"doing a global Mail.app search for numeric strings, especially with a decimal point, doesn't work reliably" -- this works with a decimal coma

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .