Ever since I upgraded to Yosemite, search no longer works properly in Finder. Spotlight works fine but Finder search just gives me a blank window with a spinning ball.

I've tried reindexing and I've also tried deleting Spotlight's .plist file. I restart my MacBook Pro after doing either. Finder search will work for one or two queries and stop again. I don't know what else I can do.

screenshot of Finder search

  • 1
    I just wanted to add that I have the same problem and it seems to be related to the indexes. I've re-indexed multiple times and neither spotlight nor Alfred (which I understand relies of spotlight's indexing to find documents) will search for documents on my computer. – Dennis Oct 30 '14 at 13:19
  • Does it randomly start working for you and go back to not working? – shahid Oct 31 '14 at 5:42
  • 1
    This time when I cleared this index, I issued first sudo mdutil -E / and then sudo mdutil -i on /. Previously I had only issued sudo mdutil -E, which from what I understand should be sufficient---it clears the index and initiates the rebuild. I hadn't turned off indexing at any point, so I'm not sure why turning indexing on would help. After a successful reindex, it seems to work for a while and then break again. It only would work for a few hours, though. This is my longest "streak" at almost a day of functioning. – Dennis Oct 31 '14 at 6:34
  • I'm guessing it isn't a common issue. Haven't noticed similar posts in other forums. What hardware are you on? Late 2014 rMBP 13" here. – shahid Nov 1 '14 at 6:19
  • 1
    I can't post an answer for some reason. But I will try to explain it here. Spotlight has some privacy settings that will hide things from the search results. Basically it takes a list of folders to exclude. In my case I had somehow managed to accidentally exclude the folder. To see the list go to System Preferences -> Spotlight. Click the privacy tab. You will see a list under "Prevent spotlight from indexing these locations". Simply remove a folder from the list to make it searchable again. In my case all of Documents was on the list, so I simply removed it and spotlight found things again. – Jon Jun 11 '15 at 0:44

Has your spotlight been botched? IN short, finder relies on spotlight to find things quickly.

This will take a while (5 or so mins) and make your Mac go into "jump-jet" mode with the fans, but:

  1. Drop to terminal
  2. type in sudo rm -rf /.Spotlight-V100
  3. then sudo rm -rf /.Spotlight-V200
  4. then sudo mdutil -i off /
  5. then sudo mdutil -i on /
  6. finally sudo mdutil -E /

Basically in sport, it resets spotlight and tells it to reindex EVERYTHING it normally should do on your "Macintosh HD". (Everything unless you've previously added entries to the privacy list)

As I said before, it'll make your fans go crazy for a while, but this is expected.

After that, all should be great! :)

  • If my Mac is quiet, does that mean I did something wrong? – shahid Nov 1 '14 at 18:33
  • @shahid As long as you notice the re-indexing, you're fine. Re-indexing is fairly intensive and so a fan-speedup would be likely. – Dennis Nov 1 '14 at 18:38
  • Adrian, what is the purpose of the first two commands? Do those folders contain the index information? Does deleting them do something different from clearing the index with sudomdutil -E /? – Dennis Nov 1 '14 at 18:42
  • @Adrian, seems to be working for me now. Let's see if problems persist after a few more searches, though. – shahid Nov 2 '14 at 19:56
  • The problem finally occurred again. Trying with these steps, now, instead of what I indicated in the comments to OP. – Dennis Nov 17 '14 at 18:12

I saw this behavior and... you know what... it's really unexplainable. I don't have a root cause (obviously) but I did resolve the problem in this way (below). I also leave a note below but I am unsure if it relates directly as to why the finder started to show results when I would search.

In general, my finder would not display any files when I opened it up and tried to make a search. Here is a picture for discussion:

search sample

What I noticed is that when I switched the button that I point to with to #2 (marked in the picture), it would show results, but if I switched to the button that I point to in #1, there would be no results.

I kept closing Finder and opening it over and over, swapping between 1 and 2. Eventually all of the different file display methods, (1, 2 and the other 2) would display results correctly when I searched for something.

I am unsure if the OS was still indexing, or there's truly a stupid bug. Check the "Note" below, because it may be related.

Note: this may not be related, but I mention it anyways... before I started playing with the Finder search, I disabled "Search Suggestions" and "Bing Web Search" by unchecking them under: System Preferences > Spotlights > Search Results.

I don't want my laptop to query the internet and use spotlight (And BING for that matter) to find things for me, if I want to make a search, i'll go to google.com.

  • Yeah, the problem went away for me. I'm not even sure what I did. I'm glad I'm not alone in this, though. I kept reindexing. I also got rid of Bing Web Search. Hopefully it doesn't come back! – shahid Oct 19 '14 at 3:10
  • Whoops, the problem is back. – shahid Oct 23 '14 at 19:20

A few days ago, the next time I started my MBP after installing Yosemite I had an issue with Finder and an existing folder. When OS X came up I was immediately presented with a window that asked me where I wanted the linked folder to OneDrive to be created at, but it had already been created under Mavericks weeks before. I could see that OneDrive was still displayed in Finder's sidebar and checked whether the folder for OneDrive was still there in my home folder, and it was. Anyway, I went through the options presented by this window and when it came to re-creating the folder in my home folder I responded yes, and it replied that the folder already existed so I cancelled the window and nothing untoward has happened since. Note that I also have GoogleDrive linked in the same way for synchronising but Finder has not had a problem with this.

  • 1
    I have neither OneDrive nor Google Drive, though. – shahid Oct 29 '14 at 5:03

protected by Community Nov 11 '14 at 17:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.