2

I recently switched to Mac from Ubuntu and I'm trying to set Adobe Acrobat Reader DC as the default pdf reader for all pdfs. I assumed this would be straightforward, however, when I download a new pdf, it defaults to Preview because if I try to set Adobe DC as default I get the following message

something.pdf can't be opened because it is from an unidentified developer. Your security preferences allow installation of only apps from the App Store and identified developers.

Then I have to go to security preferences and explicitly approve Adobe Reader. This is incredibly annoying because Preview doesn't support tabs and I tend to have several pdfs open at any given time and don't want to open each in a separate window.

Is there a way to change the security preferences such that all opening all pdfs with Adobe reader is allowed by default?

I'm on MacOS Mojave.

  • You can also completely disable Gatekeeper (the mechinism that prevents apps from “unidentified developers”) by running sudo spctl --master-disable in the Terminal. Sounds like you don’t need to though, and it is somewhat less safe. – Wowfunhappy Aug 3 at 14:52
3

Select a pdf file in Finder and click the Command-I keys to display the Get Info panel. Click on the lock icon at bottom of the panel and enter your password. Then click on the "Open With" pull down and select Adobe DC and click the "change all" button. This sets Adobe as the default for pdf files.

enter image description here

  • Thank you so much! This fixes the issue. – fbartolic Aug 3 at 14:37
  • Glad i could help! – jmh Aug 3 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .