0

On macOs High Sierra I am trying to set a default icon for .pdf files: when I used Adobe Reader all the pdf files showed its icon, then I uninstalled it and replaced it with Foxit Reader as default app to open the same file. However all the pdf files now show a white icon and I would like them to show the Foxit logo instead. I tried to copy-paste the logo from Foxit to a random pdf and it does work, but this cannot be applied to the whole configuration (this means that I should copy-paste everytime the logo in every single pdf file). Is there a way to set the default icon?

1

Once you have changed the default application using Get Info, you may need to clear the icon cache.

To get started, close all open applications and then launch Terminal from Macintosh HD > Applications > Utilities. Copy and paste the following command at the Terminal prompt and press Return to execute it:

sudo find /private/var/folders/ -name 'com.apple.dock.iconcache' -delete
sudo find /private/var/folders/ -name 'com.apple.iconservices' -delete
sudo rm -r /Library/Caches/com.apple.iconservices.store

Restart, job done.

From Safari download bar rar file icon show as VLC icon,which associate to The Unarchiver should shows its icon

  • I did what you explained but the problem still exist. I have updated to Mojave since the last time. In Finder (choosing the list view for my files) I still see .pdf icon represented as a blank page. – Lorenzo Jan 7 at 17:24
  • It appears Foxit Reader is missing the readerpdf.icns file. As a quick fix until the developer releases a solution you could borrow the PDF icon from another app or find an icon from a previous version. – TimD Jan 8 at 4:46
0

When you had the Adobe Reader installed, it was the default PDF reader and that's why all the PDF files have that icon. You can do that same by setting the Foxit Reader as default PDF reader. Follow the instruction below.

Select any PDF file and press Command + i. You will get and Info page. Go to "Open With" selection and select "Foxit Reader" from Applications. You will find an option "Change all". Select that and it will set the app as default PDF reader and will change the icons.

  • First of all, thanks for the answer. However I have already set Foxit as default pdf reader in the same way you explained and still my icons are white. The same happens with some MATLAB files (.m), but I am not that intrested in changing them: I have a lot of pdf files, so it is pretty bothering to have them all white. – Lorenzo Oct 19 '17 at 8:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .