4

I have nothing against Mission Control but don't use it much except now when my secondary click opens it every the time.

I usually want the secondary click to open a context window like I now have to do with the ctrl single click.

On my trackpad I use the two finger tap as secondary click as per below settings. With a mouse it's the right button. In both cases Mission Control is opened instead of a context window.

For full disclosure I mention that I make use of BetterSnapTool and Alfred3 but when I unload them the issue persists.

enter image description here enter image description here enter image description here enter image description here enter image description here

  • Does the problem persist if you create a second user account and test there? – Ashley Jun 4 at 21:30
  • No it doesn't. Good hint! – Jurgenfd Jun 5 at 6:53
  • So how do I find the differences between my account and the second user's to get rid of this behaviour? Should I check for other third-party apps like my VMWare Fusion? – Jurgenfd Jun 8 at 10:11
1

As a troubleshooting step I would start with booting into Safe Mode to see if the behaviour is replicated there, and also to see if the behaviour continues again afterwards when you've logged back in normally.

Boot into Safe Mode

Follow these steps to boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. does secondary click still opens Mission Control?)
  6. Now exit Safe Mode by restarting your Mac as normal
  7. Log in normally and test again

Once you've booted into Safe Mode, let me know how you went and we'll go from there.

Trash your Mission Control preferences

Now that we know the problem isn't caused by a 3rd party extension etc, let's trash the preferences for Missopn Control and see what changes that maes.

  1. Go to Finder
  2. In the menu bar click on Go > Library (Note: If the Library option doesn't appear, hold down the option key while clicking on the Go menu)
  3. Within the Library folder, look for and open the Preferences folder
  4. Now look for com.apple.spaces.plist and move it to Trash
  5. Restart your Mac
  6. Log back in and empty your trash

Now test again and let me know how you went and we'll go from there.

  • The unwanted behaviour is present under Safe Mode as well. The behaviour continues again afterwards when I've logged back in normally. Cheers, Jurgen – Jurgenfd Jun 8 at 10:05
  • Thanks for getting back to me. I've added another troubleshooting step. – Monomeeth Jun 8 at 22:16
  • Done as per below but the problem persists. ``` cd '/Users/jd/Library/Preferences/'; [jd@Elf:Preferences]> rm com.apple.spaces.plist* remove com.apple.spaces.plist? y remove com.apple.spaces.plist.6nvZnHi? y remove com.apple.spaces.plist.IWanu2a? y remove com.apple.spaces.plist.lockfile? y remove com.apple.spaces.plist.qFz2PKQ? y ``` – Jurgenfd Jun 9 at 9:56
  • I ended up using a new account as the best workaround I know of. – Jurgenfd Jun 27 at 16:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .