0

I am experiencing some really annoying issues when using a secondary display on my 13-inch Retina Macbook Pro with OSX 10.12 (Sierra).

I use two different external displays (one at a time): my iPad Mini with the Duet app and an LG M2550D with an hdmi cable. In both cases, Mission Control is not opening when I have the secondary screen plugged in. I tried disabling and enabling Mission Control, rebooting the computer, reinstalling Duet, changing the hdmi cable for the monitor and nothing has worked. I also tried using the trackpad gesture, the mouse button I have assigned for this and the keyboard F3.

Also, when I'm using the LG monitor, my mouse won't work as well (as if it is unplugged). When I unplug the hdmi cable, the mouse "starts working again". It is a Logitech MX Performance.

Can you help me? I really don't know what else to do.

Thank you very much.

1

Mission control not opening is caused by Duet disabling it due to a bug in Sierra. I've just done a Google and found that apparently the bug is fixed in OSX 10.12.2 which is in beta and hopefully released soon.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .