1

I have a 27" iMac Retina (Late 2015, 3.2GHz i5, 24GB, Radeon R9) with HDMI secondary screen on a Thunderbolt/HDMI adapter. I use Mission Control to put 4 workspaces on the main monitor, and switch back and forth using control-arrow keystrokes. This still works, but screen hot corners to view Mission Control, Desktop, etc. do not work any more. Also, I use auto-hide for the task bar, and moving the mouse to the bottom of the screen no longer pulls up the task bar -- as of today, I have to click at the bottom.

Everything had been working fine until a recent High Sierra update (maybe 1-2 updates ago?). When problems first started, I deleted ~/Library/Preferences/com.apple.dock.plist and restarted Dock a few times, and eventually got things working again.

Today, none of that has helped: hot corners doesn't work, auto-hide taskbar only works with a mouse click, and I can't click and move windows after I use a keyboard shortcut to show the Mission Control overview. (I can select a window in the overview and it gets popped to the top of the stack, but I can't click-and-drag windows any more.)

It looks like there's something wrong with the mouse (a Razer connected by USB), but an old generic USB mouse doesn't work any differently. So perhaps the problem is in mouse / UI handling?

I also have a couple of MacBook Pros which have all the same updates (I think) but the magic trackpad shortcuts to show Mission Control haven't had any problems, and I think Bluetooth mice attached to them are working OK (have to check to be 100% sure).

I have had some other trouble with some user input on the iMac: I use VMWare virtual machines, and both Win10 and Linux guests sometimes miss key-up events, so I either get control/alt/shift stuck down, or I get keys repeating (or both). Clicking the affected key a couple of times usually fixes this. I also use VMWare and Parallels on the MBPs with no problems.

Are there any known problems with UI on iMac on recent High Sierra? Any workarounds?

  • I tried a Bluetooth Magic Mouse on the iMac, but no difference -- Hot Corners and auto-hide doesn't work. Two-finger swipe works to switch between workspaces, and two-finger tap calls up the Mission Control overview, but I still can't click-and-drag windows in the overview. – Dave M. May 10 '18 at 16:19
1

Apple Support was willing to help me troubleshoot, even though I don't have a current support contract. We tried several things, and eventually determined that a desktop/window manager add-on called Magnet was messing up the UI events. (I had tried just turning off the add-on, but that didn't work.) It was some other troubleshooting step, including:

  • Reset NVRAM (shutdown, power up with Opt+Cmd+P+R)
  • Safe-mode Boot (Restart, hold Shift during boot)
  • Create new admin user, log in (this helps distinguish a system problem from a particular user's preferences problem)
  • Disable startup items

Resetting NVRAM didn't help, but safe mode worked. (However, safe mode turns off all graphics acceleration, so it's really slow on a Retina machine.)

The new user didn't show the problem, so it was clearly something in my preferences / profile.

Finally, turning off Magnet auto-start and rebooting cleared up the problem in my user account. I was subsequently able to turn Magnet on again, and it's working OK now. So I suspect it was a stray preference that conflicted with an OSX upgrade, which got cleared out by the rebooting and other troubleshooting steps.

I'm extremely grateful to Apple Support for the help!

-1

Turn off WindowTidy or Magnet, restart and reset NVRAM, then everything is fine.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .