13

The trackpad gesture to call Mission Control or Expose with three-fingers does sometimes not work for some reasons. It works when I use four-fingers, and it functions as usual whenever I open my System Preferences and reset the Mission Control and Expose section to use three-fingers gesture (instead of four-fingers). However, it's set to three-fingers at first, and it's just that I first disable it and then enable it again...

The symptom occurs whenever I restart my Mac, so it's nothing but tedious to bother to open my System Preferences to check off and then on to the Mission Control and Expose checkboxes. As I said, when I reset the setting, it works as usual.

My trackpad is Apple's Bluetooth trackpad, and my Mac Pro is late-2013 machine. I also use mid-2012 MacBook Pro with Retina display, and while it might occur on the machine at times (maybe only a couple of times per 1,000 sessions), I have not had such issues almost usually.

Is there anything that I should investigate further? PRAM and SMC didn't resolve the issue... I'm curious to know why it occurs whenever I restart my Mac, and how to solve the issue.

I use the latest version of Mavericks.

27

This sometimes happens to me, where the 3-finger macro stops working. Seems like OSX just bugs out. My hotfix right now is to open the command line and run killall Dock. Seems to work fine for resetting it and getting it working again.

| improve this answer | |
  • you sir are a GENIUS – Radu Simionescu May 22 '17 at 13:53
  • perfect! This worked like a charm when my Mac didn't want to let me switch between desktops or full-screen apps. Not just gestures, but regardless of method. – Canis Oct 21 '19 at 22:35
1

What I did was to turn of all gestures that use three fingers, shut down, power up then re-enable all three figure gestures, and this worked.

| improve this answer | |
1

I had the same issue on macOS Catalina (and I had it on macOS Mojave as well. The problem with Mission Control was the reason I upgraded), but it turns out it was Mission Control that not worked (would not open using keyboard either). This solved it for me;

  1. Open a command line shell in Terminal application (search for Terminal in Spotlight if you're not familiar)

  2. Copy and paste the following command:

    defaults write com.apple.dock mcx-expose-disabled -bool FALSE

  3. Copy and paste the following command (restart the OSX Dock):

    killall Dock

| improve this answer | |
0

As far as I have searched for the similar issues on the Web, I'm sure this is a bug by Apple. The interim solution is turn both the Mission Control and Expose checkbox off on the System Preferences | Trackpad, and then use BetterTouchTool to allocate the three-fingers swipes to the two actions.

I also tried to create a launchd on which I overwrite the default setting with defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad TrackpadThreeFingerVertSwipeGesture -int 2, but it didn't work.

| improve this answer | |
0

The trackpad gesture to call Mission Control or Expose with three-fingers does sometimes not work for some reasons

If your other finger gestures are still working, then the reason why Three Finger Swipe seems to stop working and work only on occasion is because:

  • Three Finger Swipe only switches between FULL SCREEN applications or windows. If you have your screen configured so that you can see your dock bar while on an internet browser, you are probably not in full screen. Press the Green button (Upper Left Usually) right next to the yellow and red, until your dock disappears and your Current Screen takes up the whole monitor. Then double check if your Three Finger Swipe is on and working.

Hope this helps

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .