11

I just did a clean install of Lion on my 2010 MBP. It seems as though in the system preferences for the built-in trackpad, I have the option of setting the secondary click gesture to "Click or tap with two fingers", "Click in bottom right corner", or "Click in bottom left corner".

Previous to this fresh install, I had simply upgraded from Snow Leopard where I had been able to initiate a secondary click either by a two-finger tap or a click in the bottom right corner. That setting was preserved when I upgraded from Snow Leopard to Lion. When I simply did a fresh install of Lion, it's now either one or the other. Not both.

Does anyone know how I can get the "both" behavior back?

4

Sadly, I don't think it's possible to do that without a third party solution. Two popular applications that allow you to tweak the touchpad and mouse are Magic Prefs and Better Touch Tool.

9

Run the following six commands, by pasting them into Terminal.app. You can paste all six lines all at once. (the last two lines aren't required on older versions of OS X, but there's no harm including them) Remember to press the return key:

defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad TrackpadCornerSecondaryClick -int 2

defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad TrackpadRightClick -bool true

defaults -currentHost write NSGlobalDomain com.apple.trackpad.trackpadCornerClickBehavior -int 1

defaults -currentHost write NSGlobalDomain com.apple.trackpad.enableSecondaryClick -bool true

defaults write com.apple.AppleMultitouchTrackpad TrackpadCornerSecondaryClick -int 2

defaults write com.apple.AppleMultitouchTrackpad TrackpadRightClick -bool true

Important: now reboot your Mac.

When you log back in, you will be able to right-click both with a two-finger tap, and by clicking in the bottom right-hand corner.

Hope this helps.

  • 1
    This also works on Yosemite – thetallweeks Dec 19 '14 at 2:43
  • I used Charlesisms method above but on 10.10.3 this doesn't seem to work anymore, defaulting to only the touchpad criteria set last in the terminal. Can anyone confirm this method is no longer working please? I'm new to Mac and could be doing it wrong, but I think I executed the commands correctly. Using BetterTouchTool I have managed to enable both but was hoping to do so with less clutter! – user121634 Apr 12 '15 at 0:00
  • @MattBaines Hmm, still working on my 10.10.3 Mac. I can still use both on my machine, and I assume I used the same commands when I upgraded the OS. Did you try using "killall cfprefsd" after entering the commands? – Charlesism Apr 12 '15 at 1:59
  • 2
    @johnmast, Thanks for the heads-up. I have added two new lines, which should work for Sierra. – Charlesism Sep 14 '16 at 18:41
  • 1
    I confirm that the above updated solutions works on macOS Sierra. Thanks @Charlesism – d6bels Oct 29 '16 at 19:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .