2

I bought a camera that works with a companion iOS app which won't run on my iPhone 4 running iOS 7.1.2. I need to get an older version of the said app. I have searched on the Internet and couldn't find it.

The app is v380. How do I get it for iOS 7?

  • Are you talking about this app? Is your iPhone running iOS 7? Please specify the make and model of your iPhone. – Nimesh Neema Jan 20 at 18:49
  • Yes, that one. I have an iPhone 4 and my iOS is 7.1.2 – Cain Nuke Jan 20 at 20:32
3

As mentioned in the Compatibility section on the app webpage, the app in question requires iOS 8.0 or later to run. You can only download the legacy version of an iOS app if the app developer continues to support it. And in case they do so, you should be able to download it using the App Store app on your iOS device.

If you are not getting the option to download the app when accessing it via the App Store app on your iOS device, the developer is no longer supporting the version of iOS running on your device. And there would be no way to download the app from anywhere else on the Internet.

In general app developers update their app with a major focus on supporting latest and recent version of iOS while dropping support for older versions.

If you have a serious/justifiable reason to run the app on older version of iOS, you can try contacting the developer via the Developer Website mentioned on the app webpage. (http://www.av380.cn/ in this case)

  • I already contacted them. I do have a justifiable reason since my iPhone wont support later iOS versions. – Cain Nuke Jan 20 at 21:29
  • @CainNuke That's nice. A likely response from the developer may be to use a newer version of iOS as they may have business reasons to drop support for older versions. – Nimesh Neema Jan 20 at 21:31
  • The problem is that my iPhone cant run versions later than 7.1.2 – Cain Nuke Jan 20 at 23:57
  • Then the next suggestion becomes get a newer iPhone – John Keates Jan 21 at 3:06
  • Great suggestion... if that was possible I wouldnt have asked in the first place... – Cain Nuke Jan 21 at 18:52
1

Here is how to download older apps, if the developer left the app in the app store. Install the business version of itunes on your computer. https://support.apple.com/en-us/HT208079 If you have installed a newer version of iTunes, read the section about Library.itl http://osxdaily.com/2017/10/09/get-itunes-12-6-3-with-app-store/Down Download the app in itunes on your computer. This will add the app to your list of downloaded apps. Now on the iPhone, you will be able to see it in the list of your apps in the appstore app. The app will appear with a cloud icon. Download it. You will get a question asking if you want to use the older version.

I used this method to download V380 to my iPhone 4 running 7.1.2. The app installed, but when run, crashes before I can get a picture of the app.

  • That sounds great. Could you please send me those versions? – Cain Nuke Feb 7 at 1:35
  • Follow the links. The download link to the business version of itunes is there. – historystamp Feb 7 at 19:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .