-2

I already read this Why does my WiFi disconnect when my Mac goes to sleep and this What is the “wake for wifi network access” setting in energy preferences?. Some answers contradict each other. Some people think disabling this option will make wifi never disconnect. and Some people think disabling this option will save energy, thus disconnect when sleep. Which one is correct?

Why do I care? I just want my wifi connect all the time unless I shutdown the machine. The current observation is that when the screen is off for some time, my networking apps are all disconnected. But the weird thing is I can still ping my macos from another computer. How can that happen? The wifi is on, but all my apps stop working. How may I avoid this failure of my applcations?

closed as too broad by Ruskes, Nimesh Neema, Mark, bmike Sep 17 '18 at 4:40

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please, what is your question? – dan Sep 16 '18 at 8:39
  • I tried to simplify your question, so as to get answers. Feel free to kill my modifications. – dan Sep 16 '18 at 8:49
  • Is your actual setting: "wake for wifi network access"? – dan Sep 16 '18 at 8:51
  • @danielAzuelos whatever. I don't care of this question anymore. thanks a lot for taking time to edit my question. – sgon00 Sep 16 '18 at 9:17
  • If you don't care about this question anymore, then why not just delete it. – user3439894 Sep 16 '18 at 9:43
0

To answer my own question, I did some tests suggested by a deleted answer.

(1) If I disable Wake for Wi-Fi network access and put macos to sleep mode, the wifi will be off. (I can not ping the wifi's ip anymore in another client.)

(2) If I enable Wake for Wi-Fi network access and put macos to sleep mode, the wifi will remain on. (I can ping the wifi's ip successfully in another client.) But even if the wifi is on, my apps will still be disconnected.

Thus, the answer in link: Why does my WiFi disconnect when my Mac goes to sleep:

After a certain time frame, more processes are frozen for the system to save energy.

Disable “Wake for network access” and you shouldn’t have this problem anymore.

The first sentence should be correct. The reason why my apps are disconnected even if the wifi is on is because my apps are frozen when the system is in sleep mode.

But the second sentence is incorrect. Disable the option doesn't solve that problem at all and even make wifi become off in sleep mode.

How to avoid apps disconnecting from network?

Avoid macos switching to sleep mode.

How to stop macos switching to sleep mode on power adapter when locking the screen or display is off?

System Preferences --> Energy Saver --> Power Adapter -->

  • Enable Prevent computer from sleeping automatically when the display is off
  • Disable Put hard disks to sleep when possible.

How to stop macos switching to sleep mode on battery when locking the screen or display is off?

System Preferences --> Energy Saver --> Power Adapter --> Disable Put hard disks to sleep when possible.

and then execute the following to disable sleep mode:

sudo pmset -b sleep 0; sudo pmset -b disablesleep 1

This command is untested yet by me and referenced from link

Not the answer you're looking for? Browse other questions tagged .