1

This Mac mini is intended to run as a kiosk, but a daily sleep/wake cycle is proving problematic with some USB devices.

My plan was to use the "dirty" shutdown from the commands line to simulate a UPS shutdown: sudo shutdown -hu now.

The process is to enable the "Start automatically after a power failure" option in Energy Saver prefs, then to execute the dirty shutdown from the command line, and finally, remove power once the power light goes out, but before the 5 minute timeout.

Tests on other minis have been successful, but this 2018 3.6 i3 Mac Mini is not consistently starting up once you supply power. This morning it started automatically when I plugged it into the mains. But later in the day, additional tests did not result in power being enabled without physically pressing the power button.

Running Mojave 10.14.6. Reset PRAM/NVRAM. pmset -g shows autorestart set to 1. The Mac WILL restart when I forcibly cut power to it.

Please note I do NOT have a UPS connected to the system.

What could be causing the inconsistent behaviour?

  • Have you tried resetting PRAM or NVRAM? – m4mac Nov 5 '19 at 18:46
  • Yes, certainly. I'll add that info to my post. – Tom Auger Nov 5 '19 at 18:49
  • What models are the other Macs? – n1000 Nov 10 '19 at 10:18
  • They are all Mac minis, ranging from 2012 to 2014 – Tom Auger Nov 11 '19 at 22:21
  • Is there any particular reason the Energy Saver Start-up/Shutdown scheduler won't work for you instead? i.stack.imgur.com/Yh1lw.png – Tetsujin Nov 15 '19 at 12:53
1

The first thing I would try is resetting the System Management Controller (SMC), as it's responsible for power management, sleep/wake/hibernation, restarts/shutdowns, and so on.

Resetting the SMC on a 2018 model Mac mini

For your particular Mac mini you'll need to follow these steps:

  1. Fully shut down your Mac mini
  2. Press and hold the power button for at least 10 seconds
  3. Let go of the power button and wait five seconds
  4. Switch your Mac mini on again

Now test to see if this has resolved the issue. If not, then try resetting the SMC with the following steps instead:

  1. Fully shut down your Mac mini
  2. Unplug the Mac mini from its AC power source
  3. Wait at least 15 seconds
  4. Plug the Mac mini back into its AC power source
  5. Wait at least another five seconds
  6. Switch your Mac mini on again

Now test again to see if this has resolved the issue.

  • This is probably the first thing we tried. Remember, this is about getting the mac to start up after a power disconnected state. So, it's basically something we do every single time. Maybe I'm not posting in the right SO channel, the basic "have you turned it off and on" suggestions are not what we are looking for here. – Tom Auger Nov 11 '19 at 18:47
0

Perhaps when you simulate a UPS shutdown with : sudo shutdown -hu now it uses the pmset settings for UPS (set with pmset -u or pmset -a).

Try running pmset -g custom to see if there are additional settings for UPS that have different values, or see if you can set the required parameters for pmset -u even though you don't have UPS.

  • No, you can't even touch the UPS controls (even with pmset) unless you actually have a UPS physically plugged in, as far as I can tell. pmset -u ... commands do nothing – Tom Auger Nov 15 '19 at 12:30
  • but did you try pmset -g custom to check if there were any existing UPS values, for example if it had previously been used with a UPS, or has it never been connected to a UPS previously. I knew it was clutching at straws but that tends to happen with 'weird' issues. – Najinsky Nov 15 '19 at 14:03
  • Thanks for the clarification. Yes, these are two brand-new Macs, with no custom settings. – Tom Auger Nov 18 '19 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .