I have a really strange issue since i updated to Yosemite. When i wake up my 2012 Mac Pro, the network connection is totally lost.

Output from dmesg (sorry, couldn't copy/paste at this time):

- Nic en0 - no link detected
- Nic en0 - link detected
- some other things (approx. 2 sec)
- Nic en0 - no link detected

Disabling/removing and adding/re-enabling in System Preferences didn't solve the issue. Only rebooting the whole machine will help. Interesting: If i remove the cable from en0 and put it in en1 (Mac Pro has two NICs), everything is fine - until next sleep/wakeup. After the next wakeup en1 is also not working. Only thing which helps is rebooting.

Tried also resetting the SMC - didn't solve it.

  • Confirming the same issue with my 2012 Mac Pro on Yosemite
    – user97895
    Oct 27, 2014 at 18:25
  • 1
    Sorry for the news but looks like Yosemite is full of bugs, and this is probably one of them. I'd wait patiently for an update. Most users are experiencing problems with their Yosemites. It's a good practice waiting till they make the first patches to an OS, to install it on our device (eg not installing Yosemite till there are some updates to the initial version).
    – lnjuanj
    Nov 3, 2014 at 21:59
  • i don't want to do a clean install on 10.9. But MacPro is unusable. One of the Keyfeatures of my Mac is instant Wake-Up. Or did i miss something? Is there a chance to downgrade without CI?
    – int2000
    Nov 4, 2014 at 13:25
  • There already exist several other entries for this like discussions.apple.com/thread/6748520?start=15&tstart=0 or forums.macrumors.com/showthread.php?t=1661896 - not solution however worked for me on a Mac Pro.
    – col.panic
    Mar 5, 2015 at 6:52

2 Answers 2


It appears to be a common issue until ~ OS X 10.10.3. I'd say your only option is to upgrade when it comes out or do a clean install of 10.10.2 and see if that works out for you. I can understand that you'd rather not do a clean install but it does actually solve a lot most of the time.

  • I'm still on 10.9. My Wife is on 10.10 with her MacBookPro. But seems a lot slower than on 10.9 - worst update ever, Apple!
    – int2000
    Apr 11, 2015 at 17:26
  • With 10.11. the problem is gone
    – int2000
    Apr 19, 2016 at 10:00

I ran into this issue as well on my iMac, but since I have dev servers running in a VM all the time, I don't put my machine to sleep, so for me, the problem was fixed by how I am using my Mac. However, I also have a MBP where this problem would crop up every now and then; especially when the MBP would go to sleep.

However, you may wish to try enabling and disabling your network interface (like turning it off and on).

Do the following:

1) Determine name of your ethernet adapter:

ifconfig -a 


ether a8:20:66:39:2c:1c 
    inet6 fe80::aa20:66ff:fe39:2c1c%en0 prefixlen 64 scopeid 0x4 
    inet netmask 0xffffff00 broadcast
    nd6 options=1<PERFORMNUD>
    media: autoselect (1000baseT <full-duplex,flow-control>)
    status: active

    ether 8c:2d:aa:3a:ec:83 
    inet6 fe80::8e2d:aaff:fe3a:ec83%en1 prefixlen 64 scopeid 0x5 
    inet netmask 0xffffff00 broadcast
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active

Mine is rather long with all the "virtual interfaces" for my VMs and I am using physical 2 ethernet connections and no Airport. So, your mileage may vary. However, for this example, let's use "en0" as our test case. Issue the following commands:

2) Bring down the network interface

$ sudo ifconfig en0 down
<Enter Your Password>

3) Bring the network interface back up

$ sudo ifconfig en0 up

That should restart that device without having to reboot the system.

Another option is to reboot your router. This worked for me as well. I am running DDWRT on my router and it has the ability to schedule a reboot and I configured it to do so every week at 3:00am. I've had zero problems with any of my Macs running 10.10.x. If your router doesn't support "task scheduling" then you will have to do it manually.

Finally, the other alternative is to disallow your Mac to go into sleep/hibernate mode. It's not the most energy friendly option, but in the interim until Apple can get this sorted out, it will save you from a ton of headaches.

  • This can be simplified as sudo ifconfig en0 down && sudo ifconfig en0 up which will only attempt to bring the interface up if in fact you managed to take it down.
    – dland
    Apr 15, 2016 at 12:48
  • 1
    I did it like that so I could explain each step, but yes, your way is much quicker and simpler
    – Allan
    Apr 15, 2016 at 13:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .