2

So yesterday I managed to screw up my iMac 2012 (with Fusion Drive) by installing the Mac OS X 10.10.2 update... The installation stalled and when I tried to restore from an external drive using Time Machine I somehow managed to corrupt my hard drive... When I try to reinstall OS X it says I don't have any disks to install it to.

Anyways, now I'm running Disk utility on the command line at boot and I see the Macintosh HD volume has disappeared. Here is a screenshot of diskutil cs list and diskutil list:

diskutil list

It seems that the Recovery HD disk is occupying the entire disk space (3TB). How do I restore Macintosh HD with a new partition so I can finally reinstall OS X?

Update 1

After deleting 'Recovery HD' on the second disk erroneously here a second screenshot of diskutil list:

diskutil list

Update 2

So I delete the LVG and LG and went to Disk Utility... (See screenshot3) But my disks are in red and DiskUtility is forcing me to fix them... (Screenshot4) And when I do Im back to the same setup... (Screenshot5).

screenshot3 screenshot4 screenshot5

Any help would be greatly appreciated...

5

Your Recovery HD doesn't occupy your whole 3 TB drive. It's disk1s3 in the diskutil listing with the common size of 650 MB.

Your Logical Volume Family and the Logical Volume vanished though.

  • To rebuild it start to your Recovery HD or to Internet Recovery Mode, open Terminal and enter diskutil cs list.
  • Copy the LVGUUID

  • To recreate the LV enter diskutil cs createVolume LVGUUID type name size

    In your case probably diskutil cs createVolume 7ABC--i_can't_read_the_rest jhfs+ "Macintosh HD" 100%.

  • Now reinstall Mac OS X or restore your system with the Time Machine backup.

Update 1:

Recovery HD doesn't exist anymore - it was deleted by accident. You have to rebuild your Fusion Drive from scratch now:

Preparation:

  • Detach any external drive (especially your external Time Machine backup drive)
  • Restart to Internet Recovery Mode by pressing alt cmd R at startup.
    The prerequisites are the latest firmware update installed, either ethernet or WLAN (WPA/WPA2) and a router with DHCP activated.
    On a 50 Mbps-line it takes about 4 min (presenting a small animated globe) to boot into a recovery netboot image which usually is loaded from an apple/akamai server.

    I recommend ethernet because it's more reliable. If you are restricted to WIFI and the boot process fails, just restart your Mac until you succeed booting.

    Alternatively you may start from a bootable installer thumb drive (preferably Mavericks or Yosemite) or a thumb drive containing a full system (preferably Mavericks or Yosemite).

Rebuild Fusion Drive

  • Booted to Internet Recovery Mode open Utilities → Terminal in the menubar and enter:
    diskutil cs list to get the CoreStorage listing.
  • Copy the Logical Volume Group UUID, it's the first listed in the listing of diskutil cs list.
  • Then delete the Logical Volume Group with diskutil cs delete LVGUUID.
    In your case: diskutil cs delete 7ABC--i_can't_read_the_rest
  • Enter exit and quit 'Terminal'
  • Open 'Disk Utility'. Enter 'Ignore' if you are asked to fix the drives.
  • Choose your SSD and partition it: 1 Partition Mac OS X Extended (Journaled), hit the Options button and choose GUID Partiton table and hit OK and Apply.
    Please check that the size is ~121 GB

    Example:

    ssd

  • Choose your HDD and partition it: 1 Partition Mac OS X Extended (Journaled), hit the Options button and choose GUID Partiton table and hit OK and Apply.
    Please check that the size is ~3 TB

    Example:

    hdd

  • Quit Disk Utility and open Terminal

  • Enter diskutil list

    Example (your disk identifiers and sizes are different of course: Your volume SSD probably has the Identifier disk0s2 and the size 121 GB and your volume HDD probably has the Identifier disk1s2 and the size 3.0 TB):

    diskutil

  • Enter diskutil cs create "Name" IdentifierSSD IdentifierHDD
    In your case probably diskutil cs create "Macintosh HD" disk0s2 disk1s2.

    Copy the resulting LVGUUID

    Example:

    cscreate

  • Enter diskutil cs CreateVolume LVGUUID jhfs+ "Macintosh HD" 100%.

    Example:

    lvcreate

  • Enter diskutil cs list
    Check the size of your Logical Volume. It should have the size ~3.121 TB

    Example:

    diskcslist

  • Quit Terminal

  • Open 'Disk Utility' and check your newly created volume for errors
  • Quit 'Disk Utility'
  • Attach your external Time Machine backup drive or check this answer if you use NAS or another network share.
  • Open 'Restore from Time Machine Backup'
  • Choose the appropriate Time Machine backup and restore your system
  • Reboot to your restored system.
  • Unmount and detach your Time Machine backup drive
  • Open 'Terminal' and enter 'diskutil list'
  • Check if your 'Recovery HD' is listed.
  • If your 'Recovery HD' is missing, usually reinstalling your current system with the latest available system installer (e.g. 'Install OS X Mavericks (10.9.5)' if Mavericks is currently installed) will recreate it without loosing any data. AFAIK Recovery Partition Creator 3.8 will NOT create a Recovery HD on CoreStorage volumes.
  • After reinstalling the system with the latest available system installer open App Store and install the latest security fixes.
  • Hi klanomath. I tried what you said but got an "Error creating CoreStorage Logical Volume Group: The target disk is already in use by Core Storage (-69753)." I think this might be due to my latest attempt at erasing the Recovery HD. Can you look at my updated screenshots? Thanks a lot for your help. – Michael Eilers Smith Feb 1 '15 at 22:21
  • I thought it was in conflict with Macintosh HD. Did I screw up? – Michael Eilers Smith Feb 1 '15 at 22:52
  • yes. I'm back to internet recovery mode. If I list with diskutil list I now see disk1 is Boot OS X (as in the first screen shot). However, I see the Recovery HD in the Disk Utility panel. What should I do now? Anyway to reconvert the Boot OS X disk to Recovery HD? – Michael Eilers Smith Feb 1 '15 at 23:18
  • Thanks klanomath. I have the Recovery HD now. However, I'm getting "An error occured while adding a recovery system to the destination disk" when restoring from TM. Any idea why this is happening? – Michael Eilers Smith Feb 2 '15 at 2:04
  • Once again...thanks for the help. I think I'm almost there. My problem is that when I go back to Disk Utility it says that I have to fix my disks (I now have 2 - HD and SDD). Look at my screenshots in my updated question. Where do I go from here? Do I partition the Macintosh HD it gives me when I fix them? – Michael Eilers Smith Feb 3 '15 at 2:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .