3

Alright, so I did something stupid today, and I really need some help right now…

So kinda like the situation in this post I think I messed up the Fusion Drive on my 1TB iMac (with BootCamp), I messed up my 1TB Fusion Drive while installing Windows 10 in BootCamp. I don’t want Windows no more, just want my Fusion Drive to be back to its original state.

So right now it’s really weird, the SSD part of the drive seems fine but the HDD part is messed up. As you can see here, I got EFI, Core Storage, and Recovery HD, they are all fine, but there are 3 more partitions:

  • 138.62GB Free
  • 104.86MB NO NAME in FAT32
  • 99.9GB Free

But OS X Doesn’t recognize these partitions at all, not even in Disk Utility, and my Macintosh HD is now “downsized" to 875 GB

Pic1 Pic1 Pic1 Pic1

I don’t want the last three partitions, just want them to be merged to Macintosh HD, so I can use my Mac with just one main hard drive. I tried everything, but still can’t manage to merge them back. I tried using El Captain Disk Utility, but can’t see any of the partition, also tried booting into Yosemite recovery disk and use the old Disk Utility, still can’t merge them back. Please give me some advice!

Below are some more detailed info I recorded:

I’m on OS X 10.11.1, iMac (Retina 5K, 27-inch, Late 2014), 1.12 TB Fusion Drive

duskutil cs list

CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group D481E62E-A993-40EF-9568-DCF708BC3B64
=========================================================
Name:         Macintosh HD
Status:       Online
Size:         881703424000 B (881.7 GB)
Free Space:   28672 B (28.7 KB)
|
+-< Physical Volume 7D7CA850-3B9D-445B-8AC9-81ABB67A8186
|   ----------------------------------------------------
|   Index:    0
|   Disk:     disk0s2
|   Status:   Online
|   Size:     120988852224 B (121.0 GB)
|
+-< Physical Volume D51952ED-5354-4B9B-A15B-5D9C8E82E7F2
|   ----------------------------------------------------
|   Index:    1
|   Disk:     disk1s2
|   Status:   Online
|   Size:     760714571776 B (760.7 GB)
|
+-> Logical Volume Family 2A62CE1E-E0BD-44C8-A1BA-7F6BCA787A87
    ----------------------------------------------------------
    Encryption Type:         None
    |
    +-> Logical Volume 5E88EF38-D2A8-4A7D-8508-5C24D948877D
        ---------------------------------------------------
        Disk:                  disk2
        Status:                Online
        Size (Total):          875848138752 B (875.8 GB)
        Revertible:            No
        LV Name:               Macintosh HD
        Volume Name:           Macintosh HD
        Content Hint:          Apple_HFS
        LVG Type:              Fusion, Sparse

diskutil list

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            121.0 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3
/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage Macintosh HD            760.7 GB   disk1s2
   3:                 Apple_Boot Recovery HD             650.1 MB   disk1s3
   4:                        EFI NO NAME                 104.9 MB   disk1s5
/dev/disk2 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           +875.8 GB   disk2
                                 Logical Volume on disk0s2, disk1s2
                                 5E88EF38-D2A8-4A7D-8508-5C24D948877D
                                 Unencrypted Fusion Drive
/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *8.0 GB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Install OS X Yosemite   7.7 GB     disk3s2
/dev/disk4 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +51.2 MB    disk4
   1:                  Apple_HFS Paragon Hard Disk Ma... 51.2 MB    disk4s1
/dev/disk5 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +3.0 TB     disk5
   1:                        EFI EFI                     209.7 MB   disk5s1
   2:                  Apple_HFS Time Machine Backups    3.0 TB     disk5s2

If anyone could help I would really appreciate it. I am really nervous right now, hope I can get this fixed soon!

  • Honestly I'd recommend erasing, then recreating your Fusion drive. Afterwards you can use your Time Machine backup to restore it. If you want to go with this option, tell me and I'll post an answer with how to do it. – At0mic Nov 19 '15 at 16:29
  • The simple solution is back things up and then boot to recovery. Disk Utility should let you clean things up as needed and then you can reload OS if needed and start again with boot camp. Could you edit the last part of the question to remove the "chit chat" and be very specific about what you want the end goal to look like. – bmike Nov 19 '15 at 16:29
  • @IronCraftMan since restoring from Time Machine might take a lot of time, I might just try this method for now, if it doesn't work I will let you know, thanks a lot! But one quick question here - recreating Fusion drive... does that keep the OSX Recovery partition? – Philip Kuo Nov 19 '15 at 17:09
  • @bmike Sorry for not bing specific enough, but goal is to remove all the unallocated disk space and unusable partitions and merge them all back to Macintosh HD. (Just like a brand new iMac). I did boot to recovery but Disk Utility wouldn't let me do anything. I couldn't remove the "additional" partitions I mentioned above. Do you got any advice? Thanks! – Philip Kuo Nov 19 '15 at 17:13
  • Your brand new mac likely had two core storage volumes, one EFI boot and recovery HD on the spinning HD. It might not be possible to put humpty dumpty back together, but let's see if one of the filesystem wizards has details on an attempt. – bmike Nov 19 '15 at 17:20
4

To expand your CoreStorage Logical Volume Macintosh HD you have to delete the blocking NO NAME EFI partition (disk1s5). The two unnamed parts (138.62 GB and 99.9 GB) are no partitions but unallocated disk space.

To remove the second EFI partition (and expand Macintosh HD) you have to boot to Internet Recovery Mode or an OS X system on an external device.

Preparation:

  • Backup your data.
  • Detach any external drive (especially your external Time Machine backup drive).
  • Restart to Internet Recovery Mode by pressing alt cmd R at startup.
    The prerequisites are the latest firmware update installed, either ethernet or WLAN (WPA/WPA2) and a router with DHCP activated.
    On a 50 Mbps-line it takes about 4 min (presenting a small animated globe) to boot to a recovery netboot image which usually is loaded from an Apple/Akamai server.

    I recommend ethernet because it's more reliable. If you are restricted to WIFI and the boot process fails, just restart your Mac until you succeed booting.

    Alternatively you may start from a bootable installer thumb drive (Mavericks, Yosemite or El Capitan) or a thumb drive/external disk containing a full system (Mavericks, Yosemite or El Capitan). If you boot from a full system on an external volume and login as a user with admin permissions (which is required) you have to prepend sudo for the gpt command below.

Remove the second EFI partition and modify CoreStorage stack:

  • Open in the menubar Utilities/Terminal

First you should get an overview of your disks and the partition layout:

  • Enter diskutil list and gpt -r show /dev/disk1 (assuming disk1 is your HDD)

To resize the CoreStorage volume you have to delete any blocking partition first (the Recovery HD doesn't count because it usually will be moved with the resizeStack command).

  • First you have to unmount all mounted volumes on disk0 and disk1 (first the CoreStorage volume, which has its own disk identifier (e.g. disk3) but resides on disk0 and disk1) then all other Fusion Drive disks (assuming disk0 = SSD/disk1 = HHD. Please check the diskutil list output for the proper disk identifiers and replace them in the commands below if necessary):

    diskutil umountDisk /dev/disk3
    

    then additional disks. Example:

    diskutil umountDisk /dev/disk0
    diskutil umountDisk /dev/disk1
    
  • Remove the second EFI partition (assuming the 103 MB partition has the index number 4 in the gpt listing you got earlier)

    gpt remove -i 4 /dev/disk1
    
  • Remount all disks in the reverse order

    diskutil mountDisk /dev/disk0
    diskutil mountDisk /dev/disk1
    diskutil mountDisk /dev/disk3
    
  • Since any blocking partition is deleted you may now resize the CoreStorage volume with

    diskutil cs resizeStack LVUUID size 
    

    in your example that's

    diskutil cs resizeStack 5E88EF38-D2A8-4A7D-8508-5C24D948877D 1100g 
    

    to expand it to ~1,1 TB (or 1100 GB) or

    diskutil cs resizeStack 5E88EF38-D2A8-4A7D-8508-5C24D948877D 0g 
    

    to expand it to the full available size (0g is a magic number here).

    The Recovery HD partition (disk1s3) will be moved to the end of disk1 automatically.

  • Quit Terminal and reboot to Macintosh HD

  • 1
    Thank you so much! I will try that tomorrow cuz it's late here in Taiwan. Hope it'll finally work for me. Thanks a lot for the help! – Philip Kuo Nov 19 '15 at 17:15
  • @PhilipKuo If you run into problem just message me with (at)klanomath – klanomath Nov 19 '15 at 17:16
  • 1
    And the wizard has been summoned. Well done @klanomath - your generosity with fielding core storage questions is commendable. – bmike Nov 19 '15 at 17:21
  • @klanomath Hello, I have a quick question here: I have done everything you said above but 1. I changed diskutil mount to diskutil mountDisk as it won't proceed with mount, is that okay? 2. I am now at the last step, entered diskutil cs resizeStack 5E88EF38-D2A8-4A7D-8508-5C24D948877D 0g but now it's showing Started CoreStorage operation [ \ \ \ \ \ ] and I think it's stuck, taking forever. Thanks! – Philip Kuo Nov 20 '15 at 1:00
  • @PhilipKuo What does gpt -r show /dev/disk1 show? – klanomath Nov 20 '15 at 5:52
-2

Literally just had to type

diskutil cs resizeStack 5E88EF38-D2A8-4A7D-8508-5C24D948877D 1100g

and it worked from terminal inside of normal-boot El Cap.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • This answer doesn't make much sense because the command as it stands now doesn't remove the FAT32 partition! – klanomath Aug 3 '16 at 18:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .