So I'm trying to restore Mavericks on an iMAC.

Internet Recovery loads fine but "Install OSX" shows no disk to select, so I run "Disk Utility".

It shows me "Untitled" drive which is a 3TB HDD (and the startup disk of course). It is "Online" and "Repair" says it's working fine. I select it but all options and buttons are disabled. I can't do anything.

I can't attach any screenshot because I'm in the middle of Internet Recovery.

Please assist.

  • 1
    Precisely which Mac model? What OS was last on it?
    – Tetsujin
    Commented Dec 8, 2021 at 16:32
  • I think it's a 2012 or 2013 iMac. Previously Windows 10 was installed directly without bootcamp. So I erased all partitions on the disk and now it is "Untitled" and I can't do anything. Commented Dec 8, 2021 at 19:52
  • Try another erase. In Disk Utility, press Cmd/2 so you can see devices as well as volumes. Erase the entire drive. GUID/HFS Extended.
    – Tetsujin
    Commented Dec 9, 2021 at 5:24
  • I don't have a Mac keyboard so I tried Windows+2 and nothing changed. Perhaps it's because there's no "View" item in Disk Utility menu? Commented Dec 11, 2021 at 7:30
  • Oh, sorry, back in Mavericks was before they hid the devices by default. You should be able to see the actual disk not just partitioning. Try a full erase as above.
    – Tetsujin
    Commented Dec 11, 2021 at 9:09

1 Answer 1


This is how I fixed the issue:

  1. Open Terminal from Utilities menu.
  2. Run diskutil list to find the disk ID. In my case it was /dev/disk0
  3. The command to erase a disk and create a new partition is: diskutil eraseDisk FILE_SYSTEM DISK_NAME DISK_IDENTIFIER so for me it was diskutil eraseDisk JHFS+ Empty /dev/disk0

Now OS X Installer sees my drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .