1

I have a 2007 aluminium iMac which I upgraded months ago to Mavericks. Today it locked up and I held the power button to shut it down and cannot get it to start again. I get the flashing folder ? icon on boot which I understand means the boot drive is not found.

  1. I tried Safe Mode (Shift after the boot sound) : nothing happened (grey screen)
  2. I tried Single User mode (cmd+S after boot sound) : nothing happened
  3. I tried recovery mode (cmd+R after the boot sound) : nothing
  4. I tried booting with the option key, nothing.
  5. I tried target disk mode with cmd+T, and it seemed to work in that it showed a different icon. However, I realized that I can't connect my new 2013 macbook to it because the latter does not have a firewire port (is there another way)
  6. I also tried disconnecting everything, including the keyboard and mouse (I have bt keyboard and a usb one so I tried both, plus mouse and trackpad, tried both)
  7. I tried reseting the PRAM and that other reset (where you unplug for 15s)
  8. Finally I scrounged out my old installation disk (Leopard) and booted Installation disk 1. When it came up, I went to Utilities in the menu and selected Disk Utility.

So far so good, but Disk Utility does not show my internal HDD, so I can't verify or repair it. It does show my time machine drive connected by firewire, and of course it shows the DVD installation disk.

What do I try next? Given this happened the way it did if there is disk corruption I think it should be minor and reparable. But right now I don't even know if I'd be able to restore a new OS.

2

Sorry Rhubarb but the next step is to physically remove the hard drive from the iMac. If you are not comfortable then the best option is to go to an Apple Store or Authorized repair center and let them do it for you.

They might even be able to test the iMac, hard drive cable, and the hard drive for you. Best case the cable just crapped out. Worst case the drive is dead and recovery is not possible. There are dozens of things in between both of those but more can be said concretely once the drive has been removed and tested in another enclosure.

  • thanks Andrew, I wondered about the cable possibility, but it's odd that the problem occurred when I hard shutdown during a screen-lock (ie all my apps were open but I just couldn't do anything) - that seems more like a boot-sector corruption than a cable issue. then again, I should be able to see the disk in that case. And perhaps a cable failure caused the lockup – Rhubarb Jan 31 '14 at 11:23
  • A hardware defect can come at anytime and show itself in many ways. It doesn't have to be limited to a single sector. It might be that the hard drive was working hard in the background to overcome many bad sectors and then failed. The HDD could also have a SMART failure. But like I said, hopefully the cable which would mean that access through external enclosure is still possible. Fingers crossed for ya – Andrew U. Jan 31 '14 at 11:30
  • Is there any chance I'll be able to get at it through Target Disk mode, if I get a thunder-bolt->firewire adapter for my new macbook? – Rhubarb Jan 31 '14 at 12:19
  • It is worth a shot but if the issue is hard drive cable then you can't. If you can access/see the drive but have issues copying/rescuing data then you got a bad drive. – Andrew U. Jan 31 '14 at 14:08
  • thanks, you get the checkmark and the point. I'm now trying - and failing - to get files selectively from the TM disk onto the new machine. apple.stackexchange.com/questions/119705/… if you have any tips on that, be much appreciated – Rhubarb Feb 3 '14 at 11:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .