0

I want to reset my iMac (late 2014, 1 TB Fusion Drive) to factory settings. As I want to set it back to Yosemite, I am using Internet Recovery (Command-Option-R) as I have installed El Capitan in the meantime.

I was able to erase the HDD just fine in Recovery Mode Disk Utility, but now I am stuck.

The OS X install dialog shows no available drive: enter image description here

In Disk Utility, the HDD and its partition settings look like this (all fields and buttons are grayed out, can't input anything) enter image description here

First Aid Verify Disk doesn't show any anomalies either from what I can tell ("The volume ... appears to be OK"). First Aid Repair went through without issues, but that didn't change anything. Tried rebooting several times but that didn't help either. I also tried El Capitan Recovery mode (just holding Command-R without Option), it looks a bit different, but the overall result is the same.

  • From the screenshots provided, somehow I have the impression that the drive is not really partitioned. I am "missing" the indented line with "Macintosh HD" underneath the existing line "Macintosh HD". Can you verify from Terminal that the partition is there? You can access that from the menu "Utilities" > "Terminal" and then type in diskutil list. – Phoenix Oct 24 '15 at 19:29
  • @Phoenix This is what it looks like: i.gyazo.com/80b5652fe5fc79eeb8e8fad40530dc8d.png – makrom Oct 24 '15 at 20:10
  • This confirms that you are missing the partition. disk0 and disk1 state that there are Core Storage partitions, but the combined size of each is not listed as an actual usable partition as disk3 (or disk4 or similar). I would try to intentionally "break" the CoreStorage device and then let it fix using Disk Utility. While I do not have a Fusion Drive myself, I can only give you general commands. diskutil coreStorage list to list core storage and diskutil coreStorage delete lvgUUID|lvgName to remove it. Coming back to Disk Utility will ask you to fix it again, then partition it. – Phoenix Oct 24 '15 at 20:40
  • For the second command above, I would read the on-screen help by just typing in diskutil coreStorage delete and replace lvgUUID|lvgName with the actual UUID you found by using the "list" command. – Phoenix Oct 24 '15 at 20:46
  • @Phoenix Just to be sure, this won't delete anything that's needed to reinstall OS X over internet later on, right? Really appreciate your help, just kinda anxious that I might break something. I guess you can tell by now that I'm not an OS X expert ;) – makrom Oct 24 '15 at 21:17
1

In Disk Utility each drive is represented by one line with indented lines underneath them for each partition (or volume) on that drive.

From the screenshots you provided, you are using a drive constellation Apple calls a Fusion drive. It consists of an SSD and a regular hard drive logically bundled together.

Disk Utility detects the logical volume group of that constellation, which is named "Macintosh HD" and by default there is a partition underneath it with the same name.

For some reasons, this is not the case for you and I also see that the partition buttons are greyed out. So, my suggestion is to intentionally break the Fusion constellation apart and have Disk Utility fix it thereafter. Here is how:

  1. Close Disk Utility
  2. Open Terminal (menu "Utilities")
  3. Type in diskutil coreStorage list and look for the UUID (you will need it in the next step)
  4. Type in diskutil coreStorage delete lvgUUID|lvgName where lvgUUID|lvgName is the UUID you found before
  5. Quit Terminal after the command finished
  6. Open Disk Utility and follow the on-screen instructions to fix the "damaged" disk

After that, you will be able to install OS X again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .