3

I have been trying to install Windows via Bootcamp on my iMac (Retina 5K, 27-inch, 2017, 3 TB Fusion Drive; Mac OS 10.12.6) and messed up. Here are the steps taken so far:

  • Ran Bootcamp and partitioned successfully
  • Rebooted to install Windows 10 and hit an error
  • Stopped Windows installation and rebooted in Mac OS
  • Tried to restore to single partition using Bootcamp and hit an error
  • Tried to restore to single partition in Disk Utility, messed up and Fusion Drive now show as 1.62 TB only
  • Ran First Aid in Internet Recovery Mode and had nothing to repair
  • Erased and reinstalled Mac OS in Internet Recovery Mode

However, half my Fusion Drive is still missing. How do I restore to a single 3TB partition? I have all my data backed up on Time Machine. Appreciate it if someone is able to help please, thanks!

diskutil cs list

CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group F3C88EBD-849D-460C-87A0-5951EB3BCA0F
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         1616854839296 B (1.6 TB)
    Free Space:   53248 B (53.2 KB)
    |
    +-< Physical Volume 19F3173E-21AA-498D-BF4D-CF0A00207DCC
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     120883990528 B (120.9 GB)
    |
    +-< Physical Volume 051E7004-96A8-4052-B376-88F56AE15CBA
    |   ----------------------------------------------------
    |   Index:    1
    |   Disk:     disk1s2
    |   Status:   Online
    |   Size:     1495970848768 B (1.5 TB)
    |
    +-> Logical Volume Family 8C0ED5DA-37D5-40D6-AE1E-9291F2738B5B
        ----------------------------------------------------------
        Encryption Type:         None
        |
        +-> Logical Volume ED2463F3-F297-4C53-88C7-6701DBF8E63E
            ---------------------------------------------------
            Disk:                  disk2
            Status:                Online
            Size (Total):          1611000053760 B (1.6 TB)
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
            LVG Type:              Fusion, Sparse

diskutil list

/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         121.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            120.9 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *3.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage Macintosh HD            1.5 TB     disk1s2
   3:                 Apple_Boot Recovery HD             1.5 TB     disk1s3

/dev/disk2 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           +1.6 TB     disk2
                                 Logical Volume on disk0s2, disk1s2
                                 ED2463F3-F297-4C53-88C7-6701DBF8E63E
                                 Unencrypted Fusion Drive

diskutil info disk1s3

 Device Identifier:        disk1s3
   Device Node:              /dev/disk1s3
   Whole:                    No
   Part of Whole:            disk1

   Volume Name:              Recovery HD
   Mounted:                  Yes
   Mount Point:              /Volumes/Recovery HD

   Partition Type:           Apple_Boot
   File System Personality:  HFS+
   Type (Bundle):            hfs
   Name (User Visible):      Mac OS Extended
   Owners:                   Enabled

   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified
   Volume UUID:              6BD5580D-FF8B-3C7A-A9D4-4328AE128DF3
   Disk / Partition UUID:    D70E2D06-129A-492F-8F2F-41952CB59CB3

   Disk Size:                1.5 TB (1504278159360 Bytes) (exactly 2938043280 512-Byte-Units)
   Device Block Size:        512 Bytes

   Volume Total Space:       1.5 TB (1504278159360 Bytes) (exactly 2938043280 512-Byte-Units)
   Volume Used Space:        733.2 MB (733249536 Bytes) (exactly 1432128 512-Byte-Units) (0.0%)
   Volume Available Space:   1.5 TB (1503544909824 Bytes) (exactly 2936611152 512-Byte-Units) (100.0%)
   Allocation Block Size:    4096 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Yes

   Device Location:          Internal
   Removable Media:          Fixed

   Solid State:              No
  • @klanomath sorry, didn't think about that! I've edited my post and added the disk0s3 info. – lis Jul 23 '17 at 4:06
  • Yikes ok, have edited the post again. Should be correct now! – lis Jul 23 '17 at 4:17
  • AdminInfo.plist and 3 folders (com.apple.boot.P, com.apple.recovery.boot, System) – lis Jul 23 '17 at 4:19
2

Your 3.1 TB Fusion Drive isn't really missing space. Stopping the Windows install and trying to revert to a previous state inflated the size of the Recovery HD at the expense of your main macOS volume "Macintosh HD". The normal size of the Recovery HD partition is 650.0 MB with ~526 MB occupied by a base macOS system and ~124 MB of free space.


Now you can either remove the oversized recovery partition (alluding to this answer: How do I regain unaccessible free space after a failed Boot Camp install on a non-Fusion drive?), expand the Logical Volume disk2 and reinstall macOS to recreate the recovery partition or you can resize your current recovery partition to a smaller but non-standard size and expand the Logical Volume disk2.

The first option takes at least 90 minutes, the second probably less than two minutes.

The second option works like this:

  • Boot to your main macOS volume
  • Get the partition list with diskutil list and here the device identifier of the recovery partition
  • Resize the oversized 1.5 TB recovery partition:

    diskutil resizeVolume diskXs3 1024m #with X either 0 or 1
    

    If you get a "too small" error choose a slightly larger size like 1088m until you are successful.

  • Get the UUID of the Logical Volume with diskutil cs list
  • Resize the CoreStorage stack with:

    diskutil cs resizeStack lvUUID size
    

    In your case that's:

    diskutil cs resizeStack ED2463F3-F297-4C53-88C7-6701DBF8E63E 3105817m
    

    If you get a "too large" error choose a slightly smaller size like 3105812m until you are successful. The larger your Recovery HD has to be in the first resize step, the smaller the size has to be here.

  • While resizing CoreStorage, I'm getting this error: Error: -69711: This operation couldn't proceed because the target's boot helper was mounted; you may want to try again – lis Jul 23 '17 at 5:03
  • Did you boot to Recovery Mode or is your recovery partition mounted? If the latter unmount it. – klanomath Jul 23 '17 at 5:05
  • The recovery partition was mounted. The resizing works now. Thank you so much for your help! – lis Jul 23 '17 at 5:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .