1

I am using iPhone 4 with iOS 6, and my boyfriend is using iPhone 5 with iOS 6 (recently upgraded to iOS 7).

Whenever I called him from my iPhone, it would say "Connecting..." when he picked up, and then after a few seconds it would say "Connection Lost". I tried a lot of times and it never worked.

Then I have my Mac setup with Facetime, and I was able to call his phone. And then I tried to use my iPhone to call my Mac (different ID), and it was connected. And then I tried to use my iPhone to call a friend's iPhone 4, and it also worked. So the problem is not on the iPhone.

So here's the summary:

  • iPhone 4 calling iPhone 5 didn't work
  • Mac calling iPhone 5 worked
  • iPhone 4 calling another iPhone 4 worked
  • iPhone 4 calling Mac worked

Any idea?

3
  • Can you call him been right next to him to test!
    – Ruskes
    Apr 2, 2014 at 20:01
  • Does the same happens the opposite way, him calling you ?
    – Ruskes
    Apr 7, 2014 at 11:39
  • Yes, it happens the same way even when he was the one initiating the call.
    – dresden
    Apr 7, 2014 at 18:03

2 Answers 2

0

FaceTime requires a very strong network connection, so I believe your issue has less to do with the device, and more to do with the type of connections you trying to use.

FaceTime works best with a solid wifi connection on both ends, or at least LTE. If either device is trying to use 3G or 4G, you will struggle to establish or maintain a decent connection.

To test this, I would ensure you are both on a good wifi connection and try it again to see how it works. If not, then you have deeper compatibility issues.

P.S. I would recommend upgrading your iPhone 4 to iOS 7.1. It has improved performance over 7.0.x and will help alleviate further compatibility issues.

2
  • We were both on a good wifi connection. Thanks for the comments, but I am not sure if upgrading to iOS7 will solve this issue because the call was already failed when he was on iOS6. I read some reviews that iOS7 is slower on iPhone 4 so I would try as much as I can to stay on iOS6.
    – dresden
    Apr 7, 2014 at 10:45
  • The initial release of iOS 7 did suffer performance issues on iPhone 4, but the recently released 7.1 is drastically better. I would recommend giving it a try.
    – Pixelwiz
    Apr 7, 2014 at 13:33
0

I no longer have this issue. What I did before trying to call again was to delete /var/logs/AppleSupport/general.log which was 10MB in size. I don't know if this has any correlation with the failure of the calls. If anyone has similar issue maybe you can try removing this file (if your iPhone was jailbroken).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .