1

I have an iPhone and a work Macbook. Despite not being logged into iCloud with FaceTime, whenever I get a call on my phone, FaceTime launches on my macbook.

I've tried logging into FaceTime, disabling wifi calling and then logging back out. Still happens.

Interestingly, there's no way to answer the incoming call. FaceTime launches in a logged out state.

4
+100

Disable Calls on nearby devices on iPhone too. Settings > phone > Calls on nearby devices.

| improve this answer | |
  • except I still want calls to go to my watch and my ipad. – marathon Dec 23 '19 at 21:20
  • Remove MacBook only – anki Dec 24 '19 at 4:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .