2

I backed up an iPad a week ago in preparation for a repair. In the new iPad, it wouldn't restore the backup in the startup process, said the OS needed to be updated. Backup is still inaccessible. Then I read that I need to make a backup first before restoring from an previous one. Did that, but the backup is still inaccessible.

It just lists the size of it and gives the option to delete it, which I don't want to do. I've tried looking everywhere, but none of the advice is applicable, e.g. go to Settings | Restrictions and do whatever, but there's no Restrictions!

Need help desperately, there's important data to retrieve. We did everything by the book, don't know why this is causing so much hassle. It would help if it gave some information about what's wrong with whatever.

Additional details:

  • IPAD AIR 4 WI-FI
  • backed up using iCloud
  • received replacement iPad
  • went through startup process
  • it stalled at "Restore from Backup" (might not have the name right), wouldn't let me select the backup
  • it said OS version must be 16.3.0 or later (may not have the number right)
  • it wouldn't let me go back or exit
  • restarting the iPad brought up the same screen
  • fumbled around and maybe after a long press of a button, it brought up some choices, one was to start over
  • went through the startup process again
  • this time didn't select any recovery options
  • updated to the latest O/S 17.1.0
  • went to Settings | Account to restore from the backup
  • backup is there 900+ MB, but doesn't give the option to recover it
  • researched on-line, it says it needs to backup first before it can recover from backup
  • backed up to iCloud
  • still no option to recover from the backup
  • researched on-line, much conflicting and incorrect advice
  • posted here
2
  • 1
    Could you list the entire process you went through, precisely? An iOS backup is OS independent [except generally it must be restored to the same or newer OS] Any restore will require the device being restored to to be on the latest iOS it can support.
    – Tetsujin
    Oct 27, 2023 at 21:46
  • 1
    @Tetsujin - entire process listed.
    – Yimin Rong
    Oct 28, 2023 at 7:43

1 Answer 1

1

The upgrade needs to happen on the iPad. If you can not upgrade the iPadOS then Apple Support would be needed if the backup is in iCloud.

Unless of course you backed up to some other device and that other device is sending the needs update message. Either way, support specializes in this sort of question and you don’t need Apple Care to get backup and restore help. Also, check with the entity that did the repair. Often they can let you know if they had to change anything relating to your setup.

Lots of details missing ( how you backed up, what exact build of iPadOS is currently installed on your iPad, etc…) to offer any more specific advice to you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .