0

My wife has a first-generation iPad Air running the latest iOS version it can possibly run (12.5.1). There is no updating it any further. She has backed it up using a 2017 MacBook Pro running macOS Catalina 10.15.4. She purchased a new 8th generation iPad. It came with iOS 14.4. She set up the iPad and then tried to restore from her backup. Finder offered her the option to restore from her existing iPad backup. She clicked that and clicked continue. It then prompted her to agreed to the "iPod" terms of service (which seems weird—it's an iPad, not an iPod). When she clicked "Agree," the iPad ejected from her computer and did ... nothing. She and I both have tried this multiple times with the same result. Nothing she or I do/try makes it restore from her 12.5.1 backup.

She contacted Apple tech support. They told her she cannot restore a backup from an older iOS version to a device with a newer iOS version. This is, of course, utter rubbish. It's actually the opposite—you can't restore a backup from a newer iOS version to a device with an older iOS version. So she's stuck with no way to restore her settings, passwords, documents, and, most importantly, game status (levels, accomplishments, etc.) to her new iPad, making her want to just return the new iPad and keep using her iPad Air until it really dies.

I know this can't actually be our fate. I've restored numerous old-iPhone backups to new iPhones in the past decade without a single problem, ever. It shouldn't be any different with iPads. Why can't we do this? How do we do this?

3

There's no general reason why you shouldn't be able to restore a backup of an iPad Air running iOS 12.5.1 on an 8th Gen iPad running iPadOS 14.4. In general, this should work without problems.

It could sound like the backup you have on the MacBook Pro is somehow corrupted.

I would advise taking a new full backup of the device, and trying the process over again.

Another way to go would be to use the "Quick Start" feature. Turn on your new (blank) iPad and hold it near the old iPad (ensure that Bluetooth is enabled). On the old iPad, you should see a popup asking if you want to setup your new iPad. When asked how to transfer data, select to transfer directly from the old iPad.

The Quick Start feature with direct data transfer is available in 12.4, so as you're running 12.5.1 you should be good to go.

3
  • The "Quick Start" you describe (starts with holding the iPads next to each other) is actually what we tried first. After about 4 hours of its just sitting there spinning with no progress bar or estimated time of completion, we canceled it and tried the traditional restore method. You are right that it could be a corrupted backup. We will try taking a new backup and doing a restore again. I'll update here tonight once we have tried that. – Nick Williams Feb 8 at 18:44
  • So, we tried re-backing up the old iPad and resetting the new iPad and trying the restore again with the same result. We also tried the "Quick Start" again, with the same hanging-forever result. I realized her version of Catalina was a bit out of date, so I installed several security updates and tried again, with the same result. (comment 1 of 2) – Nick Williams Feb 10 at 19:00
  • Then it occurred to me that she wasn't encrypting her iPad backups (so not a full backup), so I enabled backup encryption and re-backed up her old iPad. Different result this time: "Could not back up the iPad because an error occurred." Spent about two hours Googling and troubleshooting this with no progress. Then, on a hunch, I decided to delete from her old iPad a custom in-house app that I wrote and installed on our iDevices for controlling our household IOT stuff. This time the backup succeeded, and then the restore to the new iPad succeeded. (comment 2 of 2) – Nick Williams Feb 10 at 19:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .