3

Edit: I upgraded to Monterey 12.1 and am still seeing the same issue. I've also updated the iPhone to the latest software version.

I have two phones, both iPhone XS running the latest iOS (15.1 or 15.2), that I backed up to my Mac yesterday from Finder. My Mac is on macOS Monterey 12.0.1. I am now having issues restoring those backups. I am experiencing the exact same issues restoring backup 1 to a new iPhone 13 and restoring backup 2 to an iPhone XS. So, the below applies to both phones:

Issue 1: When I plug my phone in and then select "Restore Backup" in Finder, the Finder hangs on "Erasing Phone", even though I can see that the phone has been erased and is now on the new phone setup screen. After waiting 30 minutes with no changes in Finder, I unplugged the phone (eject didn't work) and plugged it back in, and then Finder recognized the phone (the name updated to the name from the backup) and automatically shows "Restoring iPhone from backup". Nice. Maybe this isn't an issue, but I wanted to include these details

Issue 2: When the phone starts restoring from backup, the Finder initially shows the progress bar moving left and right (i.e. it feels like it's doing something but still deciding how long it will take), but after maybe 10-20 seconds, the progress bar shows completely filled, and there's no animation or indication that anything is happening. This is what I see:

Restoring from backup with progress bar filled

Meanwhile, my phone just shows the "Connect to Mac or to a PC with iTunes" screen and gives no indication that a restore is in progress. I can even tap "Back" and continue with setup.

I left my phone connected for several hours just in case it was working, but the screens never changed, so I disconnected my phone, and it is still in the initial setup state.

For Phone 1, I gave up and tried restoring from the old phone with Quick Start (holding the phones next to each other), and that failed three times in a row after almost two hours each time. I ended up backing up the old phone to iCloud and restoring that way, which worked great.

For phone 2, I no longer have the old phone, so restoring from this Mac backup is my only option.

1 Answer 1

4

I was eventually able to get this to work. After updating to the latest macOS and iOS versions and still not having success, I decided to put my phone into recovery mode and choose the "Restore" option. This did a full factory reset and updated the software (which I thought I had already done, but maybe this was different).

I then went through the initial phone setup flow on my phone and chose “Restore from Mac or PC backup”, just like I'd done so many times before. This time, when I opened my phone through Finder on my Mac, the UI was a little different. It was a simpler screen that seemed tailored to a new phone setup as opposed to the normal "Sync phone" screen that shows storage, sync options, etc. The only options were to set up the phone from scratch or restore from a backup. I selected my backup.

This time, the iPhone changed to say “Restore in Progress” (I had never seen that) and did not erase the device first, which is something that always happened from the other Finder UI. The progress indicator worked, and the restore took maybe 2-3 hours and was successful.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .