1

I am struggling to restore my system from a MacBook Pro of one generation to a more new one.

What I have tried:

  1. I restart the system in recover mode: "cmd + r"
  2. I choose the proper backup version from my Time Machine hard drive
  3. I "Accept" but id doesn't allow me because is a different model and it recommends to me to choose "Reinstall macOS" and wait for the option of restore from Time Machine during the reinstallation process ("You can't restore this backup because it was created by a different model of Mac")
  4. I choose "Reinstall macOS" but after 30 minutes of install process not option about using an existing Time Machine backup asked
  5. I am expecting to see the "Setup assistant" but at the end of reinstall process my system restarts with the old installation (with the old Users and everything)

I have tried this process several times, always with the external disk with the Time Machine version connected, but always the above same result.

What can I do to make my Time Machine backup appear when installing macOS?

  • I have tried to restart the computer also with the options "Option-Command-R" and "Shift-Option-Command-R", reinstalling macOS from these options also is not showing the "Setup assistant" – fguillen Oct 8 '17 at 15:38
0

I’ve always had luck just installing the os version I want. Then when the setup assistant runs, connect to the Time Machine backup and proceed to select what you want to restore.

  • No luck, as you can see in my (updated) question and comment, the reinstall process never ends with the Setup Assistant, the computer restart with the old installed version with the old Users and everything :/ – fguillen Oct 8 '17 at 15:41
0

The solutions was to "Delete the local Hard Drive" before ask for "Reinstall macOS"

  1. I restart the system in recover mode: "cmd + r"
  2. Choose "Disk Utility"
  3. Use "Disk Utility" to Erase the local Drive
  4. Choose "Reinstall macOS"

Then, after reinstallation, the "Setup Assistant" is finally triggered and I can restore from my Time Machine backup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .