2

Previously when I used an Intel Macbook Pro with 10.14.6, I could press ⌘ + space and instantly start typing and Spotlight would register everything I typed, but since switching to an M1 Pro Macbook Pro with 12.6.1, it takes about a half a second for the window to show up, so when I type at my usual speed it misses the first two characters.

The same issue occurs in safe mode, when being logged in as another user, after having unloaded the Spotlight daemon and loaded it again, after having reindexed the drive, and after having reinstalled macOS. I also tried unchecking all the "search result" options under Spotlight in System Preferences. I've had the same issue previously under Intel and Mojave, but it was solved after a system update (upgrading to 12.6.2 didn't change anything), and I know macOS 13 is available but I'd like keep using Monterey for a while.

1
  • 1
    I can confirm that an M1 iMac is slower than a 2012 Mac Pro still on Mojave… but only the first time. Subsequent invocations are as fast as I can type. The Mac Pro is as fast as I can type every time.
    – Tetsujin
    Nov 14, 2022 at 17:30

2 Answers 2

0

If you update to macOS Ventura this problem will be fixed.

1
  • well.. This did not fix it for me.
    – itsafire
    Feb 2, 2023 at 11:15
0

I found that deleting Spotlight's metadata and let it rebuild its index made Spotlight much faster for me and uses much less CPU power. You can do this by entering the following commands into terminal.

Note: You may need to disable SIP to run the following commands:

Step 1. This turns off indexing:

sudo mdutil -a -i off /

Note: It'll prompt you with your Mac's admin password when running the first sudo command prompt above, but it shouldn't for the sudo commands in the following steps below. Your password will not show up in the terminal window when you type it, so be careful not to make mistakes or otherwise it'll just re-prompt you until you enter the correct admin password

Step 2. This kills (quits) spotlight

sudo killall -KILL Spotlight spotlightd mds

Step 3. This deletes spotlight indexing metadata

sudo rm -rf ~/Library/Metadata/CoreSpotlight/

Step 4. This deletes other spotlight data

sudo rm -Rf /System/Volums/Data/.Spotlight-V100

Step 5. This turns on indexing again

sudo mdutil -a -i on /

Step 6 (Optional). Restart your Mac (but not necessary) after completing step 5. Also re-enable SIP again if you disabled it earlier.

Step 7. Give Spotlight some time to reindex your Mac (particularly if it has a large data disk).


This worked for me on my 2013 MacBook Pro (Intel) running on macOS Big Sur, so I'm not sure if this will give you the relief you're seeking for your M1 Mac, but it is certainly worth giving a try! The commands should be the same on macOS Ventura. If it isn't, the location of the Spotlight metadata might be in a different directory/file path, but otherwise the commands are the same.

Hopefully this fixes it for you, because it certainly made my Spotlight much more responsive!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .