2

Why is the Spotlight search index not finding what seems to me to be the most obvious result for a core app?

I search for the Calendar and it gives me a bunch of useless results. I did a fresh OS update, cleaned the index, forced a re-index, actually saw Spotlight doing a re-index process - nothing helps.

Calendar isn't the only app I'm having issues with. I don't know if it's some bias, but I feel like over the years the search has become less and less accurate.

Is there a way to customize Spotlight search to first aim for certain type of results, f.e. "always search for apps first, then go to internet suggestions, etc..." ?

I mostly use Spotlight to open apps, so I'd like to point it mostly in that search direction.

UPDATE: screenshot of my Spotlight preferences at the bottom.

UPDATE 2: I changed the Spotlight preferences as shown in the screenshots below and reindexed the whole Macintosh HD. Also tried de-selecting and selecting back the Applications preference and forcing a re-index. The issues persist.

Seems like the issue is only with certain apps. Most of the apps are being the first search result suggestion, but some apps don't appear at all. So far namely: Calendar, System Preferences, Activity Monitor, Notes.

IIRC, at OS Catalina I had no issues. When I upgraded to Monterey yesterday, things started getting icky with Utility apps like System Preferences and Activity Monitor.

UPDATE 3: Ok, getting some more info from this answer and considering that I just updated from Catalina to Monterey (skipped BigSur), there is a pattern in that only built-in apps are not showing up in Spotlight. I tried adding the /System/Applications folder to the Privacy tab of Spotlight settings, and then removing it, triggered a re-index, but that didn't fix things.

enter image description here

Here's another example with "System Preferences":

enter image description here


enter image description here


Spotlight preferences:

1. enter image description here

2.

enter image description here

9
  • This is very weird. Even on my MBP where the primary language is german I can type "calen" and it shows the "Kalender.app"
    – X_841
    Nov 22, 2021 at 11:28
  • I know it sounds weird, but have you tried unticking the checkbox for Applications, restarting, then re-ticking Applications?
    – IconDaemon
    Nov 22, 2021 at 12:24
  • Also, check what's in Privacy, just in case the path containing apps got added accidentally.
    – Tetsujin
    Nov 22, 2021 at 12:36
  • @Tetsujin That's not the case. Nov 22, 2021 at 12:36
  • @IconDaemon I've tried that as well. Not helping. Nov 22, 2021 at 12:37

2 Answers 2

3

Ok, I figured it out with the great help from comments! What I wrote in Update 3 and the info from this article: Fixing no Spotlight results on macOS Big Sur led me to the solution:

the built-in apps have been moved to /System/Applications starting BigSur (I updated from Catalina to Monterey a day ago). I ran sudo mdutil -sa to find out:

 /:
Indexing disabled.

So, I ran: sudo mdutil -i on / which would enable indexing on /System as well. Now I can also see the built-in apps in the Spotlight search results.

1
  • I had /: Indexing enabled. but also /System/Volumes/Data: Indexing disabled.. Doing sudo mdutil -i on /System/Volumes/Data fixed it. Why do I need both? No idea.
    – Juliano
    Apr 24 at 23:10
0

I have seen cases where some file or files on the system interrupt the indexing process and since that proceeds in a non-obvious pattern (to my eyes), you might have apps that show up and then don’t if there’s an issue with the importer.

I often make a second account on the Mac and sign out of the first - then sign in to the second account to let spotlight make a new “base index” for that user. I also eject all disks except the OS disk before logging out and disconnect them - they can influence search when connected.

From there you can attack this based on the issue causing it:

  • could be settings
  • could be disk corruption
  • could be file corruption (or spotlight crashing on some good files)
  • could be user specific issues

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .