3

I originally had the Notes app syncing to my Google account. I changed my google password 8 months ago and never bothered to update it on my machine. Today I went to Notes/Accounts and unchecked the Google box (because I wanted to use iCloud to back them up instead). All my notes disappeared. Since I wasn't logged into Google they weren't saved in Google. During troubleshooting I logged into Google locally and it restored some Notes (but only those from before 8 months ago). The ones I've written since then are gone.

Luckily I backed up my computer a few days ago so I believe this data is on my external hard drive. I've tried multiple ways to restore. First I used TimeMachine to restore the Library/Group Containers/group.com.app.notes files but no notes show up. I tried to open the .sqlite files directly in my terminal. And I tried this method but received a message that no notes were found (its an answer from 2018): Can't restore my notes on macOS

The Apple store told me to erase my computer and restore it from the backup but that seems extreme (and they're not sure it will even work).

How can I get my notes back from the time machine backup?

Here's view of my backed up notes folder: Library/Group Containers/group.com.app.notes enter image description here

1 Answer 1

0

The Notes files you need to restore are in Containers and Group Containers, both must be restored from back up. The files are com.apple.notes in Containers and group.com.apple.notes in Group Containers.
The Library folder in the path mentioned may be hidden so press Shift/Command/Period together to reveal. Both GC & C folders are in same Library folder. Path: User/Library(may be hidden)/Containers/com.apple.notes etc.

Select each file, don't open, and copy to desktop. Do same procedure, same folders on your data storage disk on your computer and paste in the copied files each into their relevant folder, again don't open.

I did this successfully following update (clean install) up to Catalina which will not see Time Machine backups by earlier OS so all had to be done manually.

2
  • Both files to be copied are actually folders containing files. There is no need the open the folders, just copy as they are.
    – Jongo42
    Feb 25, 2023 at 5:46
  • If this comment is relevant information for the answer, please edit the answer to contain it. Comments may be deleted. Mar 27, 2023 at 16:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .