1

I stupidly shut down my MacBook when there's data transferring between my Mac and this external SSD (connected with a USB-C cable).

Afterwards, none of my following devices recognize this SSD

  • my MacBook with USB-C running macOS Monterey 12.3
  • iPad Pro with USB-C port running iPadOS 15.4
  • a laptop with USB-C port running Windows 11

This SSD is SanDisk 1TB Extreme Portable SSD.

On my MacBook, this SSD does show up under the USB Device Tree as shown in screenshot below SSD appears in USB Device Tree

but it shows up neither in diskutil list nor in Disk Utility (show all device).

enter image description here

Disk Utility with Show All Device

Is there a last ditch effort I can try before I declare the death of this SSD?

Edit 1:

Output of ioreg -lw0 | grep -i -C 200 55ae

Please see this GitHub gist: https://gist.github.com/patricorgi/7138b0baa104fbe38ec113177d0a21df

6
  • I am no expert, the fact that it shows up in system info makes me believe it is not dead. Also, when you shut down, did you do that via the OS or press a button? Because if you did a proper shutdown, I see no reason why this should harm an SSD at all. Even a hard shutdown should not do anything to it. Have you selected show all devices in disk utility?
    – X_841
    Mar 21, 2022 at 13:49
  • I forced the OS to shut down by holding the power button. I did select to show all devices in disk utility. I guess perhaps the pointer to the first sector of this SSD lost and it could not be restored after the forced shutdown.
    – Patrick
    Mar 21, 2022 at 18:53
  • Can you add a code block with the result of the following? ioreg -lw0 | grep -i -C 200 55ae
    – pion
    Mar 22, 2022 at 7:29
  • Yes, please check out this gist: gist.github.com/patricorgi/7138b0baa104fbe38ec113177d0a21df
    – Patrick
    Mar 22, 2022 at 9:21
  • Just came here to say I have the same issue with the same device. My Mac shut down during a power cut and now the device is in the USB but no volumes are detected by the Sandisk security s/w. Think these drives are not reliable in the event of a power outage. Oct 5, 2022 at 16:53

2 Answers 2

1

The SSD appears to be faulty. diskutil list should show the drive (and its total capacity) regardless of the disk's contents, e.g. even if there is no partition on it. The same behaviour (USB device detected but with no block device) can be observed when connecting a "SATA-to-USB" HDD/SSD enclosure withOUT a drive inserted in it. Also the "SCSI Logical Unit Bytes" = <0001000000000000> you posted in the gist looks suspicious.

Some drives support encryption and disable access until unlocked. If you have enabled encryption earlier, you will need to unlock it first (or disable the encryption). But in my experience (other manufacturers like WD or Samsung, not SanDisk*), the "SED" encrypted drives still report the correct capacity (only all read/write attempts fail when locked), or show up as a small partition, which sometimes appears as a virtual CD drive, with tools to unlock it... You can try downloading SanDisk Security software to see if it detects the drive, and then unlock the drive, or erase it if you forgot the password. (knowledge base article with screenshots showing what the process looks like)

In case the drive is not detected even in that utility, I would recommend contacting the drive manufacturer, or seller for RMA.

*I know WD and SanDisk have merged, but even new devices might still behave differently for historical reasons.

1
  • Thanks for replying. This still didn't solve my issue unfortunately. Actually at this moment, I'm almost certain my SSD has some serious issue and could not be resolved by any software means. At some point I may take it to data recovery professionals. Thank you again!
    – Patrick
    Aug 27, 2022 at 20:54
0

I’m on mobile, and can be partially helpful :)

Open Terminal from Utilities (/Applications/Utilities/Terminal)

Type:

Diskutil list

You’ll get a list of drives, carefully look for your drive as the names would be in a format like (/dev/disk1s3) etc

Basically you’d need to manually FORCE mount the drive.

You can Google about the exact command as far as I remember it involves following steps.

  1. Create a folder named myVol in /Volumes

    Cd /volumes

    Sudo Mkdir myVol

You’d be required root password. Make sure you write your disk name somewhere for the next command.

  1. Sudo mount force msdos -t /dev/disk2s1 /Volumes/myVol

I hope I’ve guided you in the right direction. If I could get some time in the morning, I’d be glad to correct if there’s any mistake.

2
  • Hi my second screenshot already showed the result of diskutil list
    – Patrick
    Mar 22, 2022 at 0:11
  • Have you tried unmount all volumes. Once I ran into such problem and luckily I had a Ubuntu disk. I opened the disk part utility on Ubuntu and then had to clean the drive. Unfortunately I have no other better idea. Good luck. Mar 22, 2022 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .