2

Hi I recently purchased a SanDisk 1TB Portable SSD. The SSD does not show up as a disk in either the Finder (with External Disks checked) or the Disk Utility (with show all devices selected).

I have a USB C Hub, Type C Hub, Amkle 6-in-1 Adapter which, has both USB-A and USB-C ports so I was able to test the following:

  1. USB-C to MacBook Air 3.1 USB-C Port
  2. USB-C to USB-C Amkle Port
  3. USB-C to USB-A Amkle Port

Out of the three possible configurations, only USB-C to USB-A via the Amkle USB Hub works. USB-C to USB-C does not work through the hub or the Mac. The following is a screenshot of the System Report when plugged USB-C to USB-A (working) through the hub. enter image description here

The following is a screenshot of the System Report plugged USB-C to USB-C (directly to MacBook). enter image description here

Is there anything I can do to get USB-C direct to the MB USB-C port working? Note that I have tried a variety of USB-C cables that I have around.

7
  • 1
    Try a different USB-C to USB-C cable. If your Mac can see a USB hub and device (using a C to A converter), the port works. The common denominator of 1 & 2 is the USB-C cable from the drive. In #3, you aren’t using that cable.
    – Allan
    Commented Jan 6, 2023 at 0:01
  • @Allan I have tried several USB-C to USB-C cables "Note that I have tried a variety of USB-C cables that I have around." Are there any sanity checks I can do to verify the cables should be working?
    – John Snow
    Commented Jan 6, 2023 at 0:05
  • Do they work with other devices?
    – Allan
    Commented Jan 6, 2023 at 0:10
  • @Allan I do not have another device to test with
    – John Snow
    Commented Jan 6, 2023 at 0:20
  • I'm starting to think that it may be the case that USB-C cables I have may not support USB 3 data transfers. I'm considering buying a Thunderbolt 3 cable to test this hypothesis.
    – John Snow
    Commented Jan 6, 2023 at 0:28

2 Answers 2

3

Well turns out none of the USB-C cables I owned supported the spec required to plug in this drive. I bought this cable from Apple which did the trick, but any cable that supports USB 3 data transfer would likely do it.

0

It seems the USB C port on the hub only for charging. The product page saying the USB C charging port; (Support 5V/3A charging).

If you just want to use your SSD with the USB C cable, I recommend a USB C to USB C Data Hub.
Such as Satchi 4-PORT USB-C Hub. And make sure connecting the hub and the SSD with USB 3.1 Gen 2(or later version) cable.

Hope this help!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .