15

I hope this can be an interesting topic also for those not affected by it. Some context first: MacBook Pro 2016 (15"), macOS Monterey 12.1, iCloud+ 200GB subscription. While it may happen from time to time for iCloud to get stuck during upload, this has been happening to me quite frequently ever since upgrading to Monterey. Syncing works normally, but iCloud seems to be processing an increasingly large amount of files which are marked as "to upload". Looking in Finder there is no dashed cloud, and I just see this: enter image description here enter image description here

Now, what have I already done? Restart Mac; shut down wait and boot; reinstall macOS; boot in Safe Mode; signed out of iCloud > restart > sign in (with the included pain of having to sync again 100+GB of data); nothing seems to have a definitive healing effect.

The only thing that seems to work around it, and that may lead to a cause is: Turn off Wi-Fi, wait until all system has gone offline Restart Mac, wait until all login items are loaded (and have realised there's no connectivity) Turn on Wi-Fi, wait and do not launch any apps, just launch Finder Here you will see the items count slowly but steadily declining until it all syncs back to normality. It appears to me that something has gotten stuck, or that something is keeping some files from uploading. I have used two utilities (Consolation and Cirrus) to browse the log and indeed when this happens iCloud seems to be stuck in a loop, but no relevant info is present there.

For records, I have a pretty fast WiFi (up to 600/250 Mbps), but I have also suspected the ISP doing something I have no idea how to check that is boggling my connectivity.

Has anyone encountered this issue, or does anyone have an idea of what could be going on here?

Is there an Apple-approved/recommended procedure to get out of it? Log out/in is no longer an option for me as it didn't solve it.

Thank you

1

6 Answers 6

10

I have a command line solution that works for me every time by dismissing that annoying stuck "uploading to iCloud" progress indicator.

In Terminal.app, the command killall bird does the trick.

The man pages for bird specifically states...

users should not run bird manually.

Frankly, I don't care if it is not recommended to run manually. It's annoying as hell to see when it's stuck and doesn't go away in Finder.

What I did is I created an AppleScript file (Kill_Bird.scpt) with this following command.

do shell script "killall bird"

Then I made a Voice Command to run the Kill_Bird.scpt file. Since I always have Voice Control activated, all I have to do is speak the phrase "Kill Bird" and ... voila

1
  • Fixed the issue instantly for me (Monterey 12.6.7), including immediately triggering sync on all devices. Cheers. Jul 16, 2023 at 11:44
6

Thanks to the second level of Apple Support I could get to the bottom of this. My iCloud Drive is working perfectly fine, but it was trying to sync files from very specific sources that should not be there. I will now list what you should look at if your iCloud gets stuck and following instructions here and here does not help.

  1. If you are using CCC (Carbon Copy Cloner) to backup anything to iCloud Drive, just stop doing that. I have had an exchange with Mike Bombich from CCC, who advised me not to do so. The reason is that iCloud seems not to like when you are adding an item of the same name to a folder, forcing it to change its name temporarily, then remove the old version, and rename the more recent one. If you can avoid it, do so, otherwise, just do not use the SafetyNet feature in addition to it.
  2. If you use Avid Sibelius, do not back up (using any backup/cloning software) files in /Library/Application Support/Avid/Sibelius to iCloud Drive.

Should this not get you unstuck, you need to perform a manual search in your Finder > iCloud Drive folder for any folder which has this symbol:

On mouseover this should read "In iCloud"

Inside those folders, look for any file that has a cloud with either dotted or solid stroke. Check what is going on and, if on mouseover it tells "Waiting to Update", then that file is having a problem. Try to remove it from iCloud Drive to somewhere local and see if the number of items stuck is diminishing. If so, continue until you solve the issue and then try to put back those files one by one.

I hope this can help others.

1
  • The last part (beginning "Should this not get you unstuck") worked for me, although for me the dotted cloud icon was on a folder at the iCloud Drive root level. (I.e., I never saw the icon pictured in this post.)
    – msailor
    Feb 17, 2022 at 0:07
4

Deleting or renaming ~/Library/Application Support/CloudDocs can force a resync of all iCloud Drive files on your Mac.

Source: https://sleonproductions.com/how-to-fix-icloud-drive-stuck-at-uploading-in-mac/

3
  • 3
    The instructions work! Still, to be on the safe side, I would be a bit more careful and choose the following procedure, Run the "Terminal" applicatiom and inside terminal window run command: cd ${HOME}"/Library/Application Support", and than du -smh CloudDocs/, show folder size, just to be safe!, and than: mv CloudDocs _stuck_CloudDocs/ (backup folder), and than: killall bird (restart sync), that's it. Thanks a lot for the advice! Feb 19, 2023 at 8:32
  • 1
    I do not see the folder CloudDocs but a folder called CloudStorage. Not sure it is the same (I have Ventura OS) Apr 7, 2023 at 9:17
  • Odd, I'm on Ventura and I have a CloudDocs directory.
    – jidicula
    Apr 8, 2023 at 2:05
1

In my experience it is caused by files with the same name. Once I rename the offending file, it clears up. The trick is finding the file.

1

You don't have to force a resync or mess around with deleting files.

On MacOS Ventura, go to settings, iCloud Drive -> Options in Apps Syncing to iCloud Drive 1. Uncheck Desktop & Documents folders and it'll show a message stating documents won't be synced anymore. Agree to it, and once it's unchecked, check it again. You won't see that uploading message anymore and you don't have to resync your files

Setting showing iCloud Drive sync options

1
  • Clarification: System Settings>iCloud> iCloud Drive and a modal will popup with Desktop & Documents Folders and the option to toggle it. I didn't try it yet. Waiting to see if killall bird helps.
    – Greg
    Apr 3, 2023 at 1:55
-1

I had the same problem for a very long time. Tried everything. Called Apple support and got to third level support but then the problem seemed to fix itself so never got a resolution from them. Even total reinstall of the OS didn't work.

Last night, I decided to focus some effort on the problem and I think it finally paid off. Here's what I did:

  1. Completely wiped out everything in icloud, including the folders for specific apps (automator, keynote, numbers, garageband).

  2. In a folder like Keynote, I deleted and non-keynote files which somehow ended up in there like stray PDFs, etc.

  3. Completely logged out of icloud by logging out with my apple ID.

  4. Logged back in to icloud with apple ID

  5. Rebuilt the app folders by opening the apps and saving a file to the icloud.

  6. Moved old files back in.

Since then, everything has been working well. Fingers crossed. My best guess is the sync with the app folders got corrupted.

3
  • Is this still working for you?
    – Christoph
    Nov 8, 2022 at 7:53
  • I'm considering moving to Dropbox ^___^'' Nov 8, 2022 at 15:45
  • 2
    @Christoph no it didn’t permanently fix the problem.
    – StevieD
    Nov 9, 2022 at 0:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .