Today, all of a sudden, during a Meet, my AirPods max completely stopped working with Google Meet. Neither sound nor mic is working.

I have the same problem with Google Chrome and Safari. It is only Google Meet that has issues, Youtube and Spotify sound fine. Other output devices, like other Bluetooth headsets, work fine.

I have tried

  • restarting chrome
  • restarting Bluetooth
  • clearing the cookies for meet.google.com
  • restarting the computer
  • removing the AirPods Max from macOS completely and reconnecting them

It sounds a bit like this, but none of the suggested workarounds there work for me.

I'm on macOS Big Sur 11.6

2 Answers 2


Excellent reference article. Since this specific web app is reported as unreliable on both macOS and windows and wired and wireless headsets, that indicates the web app itself has issues with sound output and not that you have made a configuration error.

If other Google apps play sound in the browser like YouTube you might need to keep trying new browsers, incognito mode (basically ensuring the web app and local data storage are not corrupted by the app) and work with the vendor to get the app fixed.


I stumbled over the solution for me:

First I gave up and switched to another, non-Apple, Bluetooth headset.

After using that for a little while, I tested switching back to the AirPods Max, and then they worked fine again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .