Ever since I updated my OS to High Sierra 10.13.6, I've been experiencing very choppy connection between my Airpods and Macbook. If I'm sitting right in front of my computer, the sound seems to cut out randomly- sometimes when I move my head slightly or walk a few steps away. However, they work completely fine when I pair the Airpods with my iPhone.

I've seen similar posts about this issue on this forum and others from google searching, but most of them are about a year old and looked unresolved. I've tried all the tips I've seen posted- I've reset the bluetooth module and always switch the Sound Input to "External Microphone" instead of the airpods, but it didn't help fix the choppy quality. (Links below)

AirPods: Extremely poor mic quality on Mac

AirPods choppy/unreliable when connected to Mac, but not iPhone

My guess is there is interference so I opened About This Mac > System Report > Bluetooth > Devices (Paired, Configured, etc.) > Airpod

Bluetooth Paired Info- Apple Bluetooth Software Version: 6.0.7f10

Devices (Paired, Configured, etc.):
Myself’s AirPods:
Major Type: Audio
Minor Type: Headphones
Services:   Handsfree, Wireless iAP, AVRCP Controller, Audio Sink, AVRCP 
Target, AAP Server
Paired: Yes
Configured: Yes
Connected:  Yes
Manufacturer:   Apple (0x6, 0x03)
Firmware Version:   0x0372
Class of Device:    0x04 0x06 0x240418
RSSI:   -72
Role:   Master
Connection Mode:    Sniff Mode
Interval:   441.25 ms
EDR Supported:  Yes
eSCO Supported: Yes
SSP Supported:  Yes

Is there a better tool to graph or detect if interference is to blame for bluetooth audio being choppy?

  • did you try with standard ear plugs
    – Ruskes
    Commented Nov 4, 2018 at 2:39
  • Yes, with normal wired earbuds the sound quality was good.
    – Matthew
    Commented Nov 4, 2018 at 2:42
  • so you were right, it is the BT connection. How did you reset the BT?
    – Ruskes
    Commented Nov 4, 2018 at 2:49
  • I held down the Shift and Option keys at the same time, and then clicked the Bluetooth symbol in the top right. Then clicked Debug -> Reset Bluetooth Module.
    – Matthew
    Commented Nov 4, 2018 at 2:52
  • do you have any other BT devices to try and are they near by ? just wondering if something is interfering with BT.
    – Ruskes
    Commented Nov 4, 2018 at 2:59

1 Answer 1


Thank you for providing more information. Out of the BT profile we can see that your RSSI signal strength is low (borderline low).

About RSSI, it is used to measure the BT signal strength (also WiFi). It is bit confusing since the values are invert. means the lower the number the better the signal.

As of this moment it is not clear why is it 72 !

As you say you are close to your Mac so the distance should not play a role in this case.

Your RSSI should be lower than 60.

The high 72 would explain intermittent connection.

As for why is it so high, it is difficult to determine from where I stand. In most cases it is just some interference from another device, like from the WiFi which also operates at 2.4 GHz band. Try turning your Mac's WiFi off to test.

If you whish to investigate Apple provides a way to do it.

Apple provides tools to actually test your Bluetooth in real time . It is on the Apple Developer site, but you must register/Log in to get them. You can find it under "More Downloads for Apple Developers"

Then download the additional tools for xcode 10 That package contains the Bluetooth Explorer.app that will analyze your RSSI signal in depth.

It will look something like this

enter image description here

Sorry I can not help you further at this time.

  • 1
    Superb answer - Would you be open to me adding a portion about the benefits / downsides of upgrading? I can add a second answer as well.
    – bmike
    Commented Jan 4, 2019 at 13:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .