2

When I connect a bluetooth headset (I have this with several headsets) it connects fine and sound goes over the headset.

But after a certain time (sometimes 10 minutes, sometimes half a minute) the headphones lose sound. The headset stays connected an still appear when I check my bluetooth settings. Reselecting the headset in 'Sound' settings doesn't change a thing.

When I turn them off and on again then it will work for a certain time again.

Restarting doesn't change a thing and the following fix that I found for other problems also doesn't fix it:

 sudo kextunload /System/Library/Extensions/AppleHDA.kext 
 sudo kextload /System/Library/Extensions/AppleHDA.kext

Anyone have an idea how to solve this?

0

This is not necessarily a macOS or Apple problem. My thought is that you have an issue with the Bluetooth device itself.

The BT device being connected isn’t a big factor here (well, you obviously need to be connected to transmit data, but that’s not what I’m referring to, here). The radio signals BT uses isn’t that much different than two way radios used way back when (think of CB radios back in the day)...

  • Theres a frequency the two devices negotiate to communicate on (breaker one-nine, breaker one-nine)
  • There’s a broadcast, a handshake and an acknowledgement to communicate (got your ears on, good buddy? I’m broadcasting in the clear, come on back!)
  • Then there’s is an exchange of data (there’s a Smokey on your six, be careful. I’m looking for some go-go juice and to put some groceries down my neck)

In a BT audio device, there’s a DAC, or digital audio converter that translates the digital data to audio. Think of it as a translator sitting next to converting CB lingo to normal speech (Smokey = police; go-go juice = fuel; groceries down neck = food)

What I believe is happening is this DAC portion of your BT device is crashing. The connection is still there, but there’s nothing to translate digital to analog and then amplify it so you can hear.

We can confirm this because nothing you do to the Mac has any effect, however, if you restart the BT device, it works again. You need to replace the BT device with a new one.

5
  • 1
    Hmm but I have tried two different bluetooth headsets and both have the same problem? – Sanne Jan 20 '20 at 13:58
  • From two different manufacturers? – Allan Jan 20 '20 at 14:02
  • Yea, one from aliexpress and skullcandy. Update: I Tried connecting a different set of bluetooth headphones. At first the sound was there but crackling so i followed the following youtube video: youtube.com/watch?v=PkBwuXwhysY&t=152s Now it seems to work ok and stay connected. – Sanne Jan 22 '20 at 10:16
  • This answer cannot be correct, since I can take that same set of headphones that is having the disconnection problem and connect to it just fine and stably with an Android tablet without doing anything that might count as restarting the device. The problem must be on the Mac. – Donal Fellows Feb 13 '20 at 21:44
  • @DonalFellows - your situation is different. There's no disconnection problem in this scenario. So, since I'm unfamiliar with your particular case, it's entirely plausible that it is the Mac and this answer is not relevant to you. – Allan Feb 13 '20 at 22:17
0

I have exactly the same issue. The only thing that works for me is to disconnect the bluetooth device and reconnect it.

It just happened again and after clicking Bluetooth + Shift & Alt I noticed that the ACC codec was no longer present.

Laptop MBP15inch2017 osx 10.15.3 Headphones SONY WH-1000XM2

VERY VERY annoying when in conference / video calls :(

2
  • Yeah i kind of just gave up it came back for me to :( – Sanne May 6 '20 at 14:13
  • Hi @Sanne, I have upgraded to the last version of OSX and the problem is GONE!!!!! You should try it :) Hope it works for you – Boyard Daniel Engels Jul 11 '20 at 11:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .